diff mbox series

[bug#52991] gnu: Add python-astral

Message ID jtS4Jr8yP3KtwzDSwMWqo4phajfrlJH3L6eSVV-ZkvVX7LecX7gBkXD0FEix1DibybhklN4FZfHXtJaKgFUfi5Acj-GnKqORRXTgGS2rE0s=@protonmail.com
State Accepted
Headers show
Series [bug#52991] gnu: Add python-astral | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Disseminate Dissent Jan. 3, 2022, 11:22 p.m. UTC
Empty Message

Comments

Vinicius Monego Jan. 4, 2022, 3:08 a.m. UTC | #1
Hello,

> ;; FIXME The directory '/homeless-shelter/.cache/pip' or its parent
> directory is not owned or is not writable by the current user. The
> cache has been disabled. Check the permissions and owner of that
> directory. If executing pip with sudo, you should use sudo's -H flag.

This can be fixed by overriding the check phase and calling pytest
manually:

>     (arguments
>      `(#:phases
>        (modify-phases %standard-phases
>          (replace 'check
>            (lambda* (#:key inputs outputs tests? #:allow-other-keys)
>              (when tests?
>                (add-installed-pythonpath inputs outputs)
>                (invoke "python" "-m" "pytest")))))))

I also adjusted the inputs as:

>     (native-inputs
>      (list python-freezegun python-setuptools-scm))
>     (propagated-inputs
>      (list python-dataclasses python-pytest python-pytz))

When the package is a module, all runtime inputs should be propagated.
I also removed python-requests since it was not being used.

> +   (description "This is @code{astral} a Python module which
> calculates times
> + for various positions of the sun: dawn, sunrise, solar noon,
> sunset, dusk,
> +solar elevation, solar azimuth, rahukaalam, and the phases of the
> moon.")

I'd reword it starting with "@code{astral} is a Python module ..."

The indentation is also off. If you're using Emacs you can use one of
its indent commands to fix it.

Could you send a v2 with these changes?
diff mbox series

Patch

From 267c0883cc7324e7cd85574478892d74534fe21e Mon Sep 17 00:00:00 2001
From: paladhammika <paladhammika@protonmail.com>
Date: Mon, 3 Jan 2022 17:56:22 -0500
Subject: [PATCH] Add python-astral.

---
 gnu/packages/astronomy.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 1f9eca9a44..3daf51dcf7 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
+;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -55,8 +56,10 @@  (define-module (gnu packages astronomy)
   #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-science)
+  #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages time)
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages video)
   #:use-module (gnu packages wxwidgets)
@@ -704,6 +707,33 @@  (define-public python-astropy
 astronomy and astrophysics.")
     (license license:bsd-3)))
 
+(define-public python-astral
+  (package
+   (name "python-astral")
+   (version "2.2")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (pypi-uri "astral" version))
+     (sha256
+      (base32 "1gkggdibccmdy9glymw3kbrkzm6svvsg0lk56hhy92y4smkrj7g4"))))
+   (build-system python-build-system)
+   ;; FIXME The directory '/homeless-shelter/.cache/pip' or its parent directory is not owned or is not writable by the current user. The cache has been disabled. Check the permissions and owner of that directory. If executing pip with sudo, you should use sudo's -H flag.
+   (arguments
+    `(#:tests? #f))
+   (propagated-inputs (list python-dataclasses python-pytz))
+   (inputs
+    (list python-pytz
+          python-requests))
+   (native-inputs
+    (list python-setuptools-scm))
+   (home-page "https://github.com/sffjunkie/astral")
+   (synopsis "Calculations for the position of the sun and moon")
+   (description "This is @code{astral} a Python module which calculates times
+ for various positions of the sun: dawn, sunrise, solar noon, sunset, dusk,
+solar elevation, solar azimuth, rahukaalam, and the phases of the moon.")
+   (license license:asl2.0)))
+
 (define-public libnova
   (package
     (name "libnova")
-- 
2.34.0