diff mbox series

[bug#63065,v2,02/16] gnu: Add bitsery.

Message ID jp6t1GbLslU1eloGCAeb_wzDCxIXzKLN7r4WM4iVKdJ26cjjcwGiWT9mJJIDLyPNfhNc1g6w3AVQWh3L5_LHLjte1aior6D6x4QuOKaYZjo=@proton.me
State New
Headers show
Series None | expand

Commit Message

Sughosha June 29, 2023, 10:17 a.m. UTC
* gnu/packages/cpp.scm (bitsery): New variable.
---
 gnu/packages/cpp.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index d61bcd25fd..40640202f9 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2094,6 +2094,30 @@  (define-public gulrak-filesystem
     (home-page "https://github.com/gulrak/filesystem")
     (license license:expat)))
 
+(define-public bitsery
+  (package
+    (name "bitsery")
+    (version "5.2.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/fraillt/bitsery")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hv2fya7w53bfhlk79b1qnjg1qy076s8kvg22sfdq05bh0hxqrxf"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:configure-flags #~(list "-DBITSERY_BUILD_TESTS=ON")))
+    (native-inputs (list googletest))
+    (synopsis "Header only C++ binary serialization library")
+    (description "This package provides header only C++ binary serialization
+library.  It is designed around the networking requirements for real-time data
+delivery, especially for games.")
+    (home-page "https://github.com/fraillt/bitsery")
+    (license license:expat)))
+
 (define-public cpp-mustache
   (package
     (name "cpp-mustache")