diff mbox series

[bug#40495] Add taisei, and spirv-cross

Message ID jZkvxKPG3fdbqhUupvY_Q8AqB9plnxUshnYZxzubWH1q3jMfdBbErjtrCb3wMAZI8wQI2-voDbET4rcZc4jlfreWlYzbpLkAquavgn1rq0E=@protonmail.com
State Accepted
Headers show
Series [bug#40495] Add taisei, and spirv-cross | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

ashish.is--- via Guix-patches" via April 7, 2020, 7:52 p.m. UTC
Hi;  taisei is a game, it has three renderers: gl33, gles20, and gles30.  To support later two it need a SPIRV-Cross tool.

   I was told on IRC that the game wasn't playable due to graphics issues, but it worked fine on my machine;  testing and help are welcome.

Game build is "developer" build; it enables cheats, but greatly improves the diagnostics (output to console).  If configured as "debugoptimized" with "-Ddeveloper=false", then it's diagnostics are same as for "release".  I didn't notice any impact on performance with my 7-years old laptop, from those options.

SPIRV-Cross seem to have tests, but i didn't get how to start them yet.

Sent with [ProtonMail](https://protonmail.com) Secure Email.

Comments

ashish.is--- via Guix-patches" via April 8, 2020, 6:54 a.m. UTC | #1
UPDATE:  Game reported playable with gles30 instead of default gl33 (both work for me, so maybe we need to change the default?)
http://logs.guix.gnu.org/2020-04-07.log#163939

Sent with [ProtonMail](https://protonmail.com) Secure Email.
Nicolas Goaziou April 10, 2020, 5:13 p.m. UTC | #2
Hello,

Vitaliy Shatrov via Guix-patches via <guix-patches@gnu.org> writes:

> UPDATE:  Game reported playable with gles30 instead of default gl33 (both work for me, so maybe we need to change the default?)
> http://logs.guix.gnu.org/2020-04-07.log#163939

FWIW gl33 works fine here. 

Some notes: you can drop quotes from descrption. They are not needed an
"..." is not a correct quoting in Texinfo.

Also, I'm not sure the last part of the description is useful. I mean,
this is the same for many arcade games, isn't it?

OOC, don't use need to add (recursive? #t) to `url'?

Regards,
ashish.is--- via Guix-patches" via April 11, 2020, 7:31 a.m. UTC | #3
(substitute* "CMakeLists.txt" with assoc-refs of respective tools enable tests... will refine further.  Thanks for a kick.

Sent with [ProtonMail](https://protonmail.com) Secure Email.
diff mbox series

Patch

From aa3c292907ac78b3df095867f39289b4a7497472 Mon Sep 17 00:00:00 2001
From: Vitaliy Shatrov <D0dyBo0D0dyBo0@protonmail.com>
Date: Wed, 8 Apr 2020 02:28:20 +0700
Subject: [PATCH] gnu: Add taisei, and spirv-cross

* gnu/packages/games.scm  (taisei):      new variable
* gnu/packages/vulkan.scm (spirv-cross): new variable
---
 gnu/packages/games.scm  | 56 +++++++++++++++++++++++++++++++++++++++++
 gnu/packages/vulkan.scm | 31 +++++++++++++++++++++++
 2 files changed, 87 insertions(+)

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 1efc50e6d1..711f4779c7 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -10471,3 +10471,59 @@  and shovers to get to the goal.  Race against the clock to collect coins to
 earn extra balls.  Also included is Neverputt, which is a 3D miniature golf
 game.")  ;thanks to Debian for description
       (license license:gpl2+))))
+
+(define-public taisei
+  (package
+    (name "taisei")
+    (version "1.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/taisei-project/"
+                           "taisei/releases/download/v" version
+                           "/taisei-v" version ".tar.xz"))
+       (sha256
+        (base32
+         "11f9mlqmzy1lszwcc1nsbar9q1hs4ml6pbm52hqfd4q0f4x3ln46"))))
+    (build-system meson-build-system)
+    (arguments
+     `(;;configure option developer=true enables the diagnostics
+       ;;needed for bug reports.  it is 'true' if not "release"
+       ;;#:build-type "release"
+       #:configure-flags
+       (list "-Dr_gles30=true"
+             "-Dshader_transpiler=true"
+             "-Dr_gles20=true")))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("python" ,python)
+       ("python-docutils" ,python-docutils)
+       ("python-pygments" ,python-pygments)))
+    (inputs
+     `(("freetype" ,freetype)
+       ("libpng" ,libpng)
+       ("libwebp" ,libwebp)
+       ("libzip" ,libzip)
+       ("mesa" ,mesa)
+       ("openssl" ,openssl)
+       ("opusfile" ,opusfile)
+       ("sdl2" ,sdl2)
+       ("sdl2-mixer" ,sdl2-mixer)
+       ("shaderc" ,shaderc)
+       ("spirv-cross" ,spirv-cross)
+       ("zlib" ,zlib)))
+    (home-page "https://taisei-project.org/")
+    (synopsis "Fangame and libre clone of Touhou Project")
+    (description
+     "Taisei is a shoot-em-up game: The player controls a character (one of
+three: \"Good\", \"Bad\", and \"Dead\"), dodges the missiles (lots of it cover
+the screen, but the character's \"hitbox\" is very small), and shoot at the
+adversaries that keep appear on the screen.  At the same time, player lose one
+\"life\" when being hit.  If player are out of \"lives\", it’s a Game Over.
+Player have a few \"Continues\" to keep playing (but without scores).")
+    (license (list license:expat      ;game
+                   license:cc-by4.0   ;resources/00-taisei.pkgdir/bgm/
+                                        ;atlas/portraits/
+                   ;;miscellaneous
+                   license:cc0
+                   license:public-domain))))
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index 6a2c219aac..e0a031141f 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -107,6 +107,37 @@  SPIR-V modules.  The project includes an assembler, binary module
 parser,disassembler, validator, and optimizer for SPIR-V.")
     (license license:asl2.0)))
 
+(define-public spirv-cross
+  (package
+    (name "spirv-cross")
+    (version "2020-04-03")
+    (source
+     (origin
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://github.com/KhronosGroup/SPIRV-Cross")
+            (commit (string-append version))))
+      (sha256
+       (base32 "0489s29kqgq20clxqg22y299yxz23p0yjh87yhka705hm9skx4sa"))
+      (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments  ;TODO: solve "No tests were found!!!"
+     `(#:configure-flags
+       (list "-DSPIRV_CROSS_SHARED=YES")))
+    (inputs `(("spirv-headers" ,spirv-headers)))
+    (native-inputs `(("pkg-config" ,pkg-config)
+                     ("python" ,python)))
+    (home-page "https://github.com/KhronosGroup/SPIRV-Cross")
+    (synopsis "Parser for and converter of SPIR-V to other shader languages")
+    (description
+     "SPIRV-Cross tries hard to emit readable and clean output from the
+SPIR-V.  The goal is to emit GLSL or MSL that looks like it was written by a
+human and not awkward IR/assembly-like code.  NOTE: Individual features are
+expected to be mostly complete, but it is possible that certain obscure GLSL
+features are not yet supported.  However, most missing features are expected
+to be \"trivial\" improvements at this stage.")
+    (license license:asl2.0)))
+
 (define-public glslang
   (package
     (name "glslang")
-- 
2.25.1