diff mbox series

[bug#49575,v3] gnu: Add python-date2name.

Message ID jXuaR7JLE6v4xhYiCx1TnXMFI34PQz8jNqQe1-MbXLa6MIpeh4BOooyHVJVjCR7R--ZrP-hGM1pd89qEPVodWwfq-GEV--tuN7CncDO7JA0=@protonmail.com
State Accepted
Headers show
Series [bug#49575,v3] gnu: Add python-date2name. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Aug. 31, 2021, 11:15 a.m. UTC
Hi Ludo,

thanks for the suggestions and excellent documentation! Here's the updated patch.
-------------------------------------

* gnu/packages/python-check.scm (date2name): New variable.

--
2.32.0

Comments

Ludovic Courtès Sept. 1, 2021, 9:04 p.m. UTC | #1
Hello,

phodina <phodina@protonmail.com> skribis:

> Hi Ludo,
>
> thanks for the suggestions and excellent documentation! Here's the updated patch.
> -------------------------------------
>
> * gnu/packages/python-check.scm (date2name): New variable.

I applied it with a couple of changes I forgot to suggest earlier:
moving it to python-xyz.scm (python-check.scm is for tools related to
test suites), renaming it to “date2name” since it’s a command-line tool
and not a Python library, and having the ‘commit’ field of
‘git-reference’ refer to the commit, not the version number.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 2a4f50ad46..afd5cb5cb9 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -13,6 +13,7 @@ 
 ;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -905,6 +906,42 @@  for the @code{pytest} framework.")
 rounds that are calibrated to the chosen timer.")
     (license license:bsd-2)))

+(define-public python-date2name
+  (let ((commit "6c8f37277e8ec82aa50f90b8921422be30c4e798")
+        (revision "1"))
+    (package
+      (name "python-date2name")
+      (version (git-version "" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/novoid/date2name")
+               (commit version)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "1vq96b7n16d932nyfhnzwdwxff0zrqanidmwr4cxj2p67ad9y3w7"))))
+      (build-system python-build-system)
+      (arguments
+       `(#:tests? #f                    ; no tests
+         #:phases
+         (modify-phases %standard-phases
+           (delete 'build)
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((bindir (string-append (assoc-ref outputs "out") "/bin"))
+                      (binary (string-append bindir "/date2name")))
+                 (mkdir-p bindir)
+                 (copy-file "date2name/__init__.py" binary)
+                 (chmod binary #o555)))))))
+      (synopsis "Handling time-stamps and date-stamps in file names")
+      (description "By default, date2name gets the modification time of matching
+files and directories and adds a datestamp in standard ISO 8601+ format
+YYYY-MM-DD at the beginning of the file or directory name.")
+      (home-page "https://github.com/novoid/date2name")
+      (license license:gpl3+))))
+
 (define-public python-pytest-xvfb
   (package
     (name "python-pytest-xvfb")