diff mbox series

[bug#49942] gnu: Add shell-color-scripts

Message ID j8v3TScCyT2ee_PoedHUN88Wwq32xEEoM11Asud9wWugE58sgw1tSxrWz7rtR9O-rJjZyZDk5xP7LkTJFLkwn8ZQgj9rFI75SGEsb8D3cw4=@protonmail.com
State New
Headers show
Series [bug#49942] gnu: Add shell-color-scripts | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Aug. 8, 2021, 11:50 a.m. UTC
* gnu/packages/terminals.scm (shell-color-scripts): New variable.

--
2.32.0

Comments

phodina Sept. 18, 2021, 8:09 a.m. UTC | #1
Hi!
Is there anything to be improved to upstream this patch?
M Sept. 18, 2021, 1:09 p.m. UTC | #2
Hi,

> +(define-public shell-color-scripts
> + (package
> +  (name "colorscript")
> +  (version "3dbdfac24bb629238fdc3e1c8909e2c8577f8735") ; no tags
> +  (source (origin
> +            (method git-fetch)
> +            (uri (git-reference
> +                   (url "https://gitlab.com/dwt1/shell-color-scripts")
> +                   (commit version)))
> +            (file-name (git-file-name name version))
> +            (sha256
> +             (base32
> +              "0lkiz6fkrqryr1vh0lh067q7hp8ba8887pkk8caipqphjswp2z16"))))
> +  (build-system copy-build-system)
> +  (arguments
> +    `(#:install-plan '(("colorscript.sh" "bin/colorscript.sh")
> +                       ("colorscripts" "colorscripts"))
> +      #:phases
> +      (modify-phases %standard-phases
> +        (add-after 'unpack 'fix-colorscipts-location
> +          (lambda* (#:key outputs #:allow-other-keys)
> +            (substitute* "colorscript.sh"
> +              (("/opt/shell-color-scripts/colorscripts")
> +               (string-append (assoc-ref outputs "out") "/colorscripts"))))))))
> +  (inputs `(("ncurses" ,ncurses)))

Missing: 'awk', 'sed' and 'coreugils'.
The colorscript.sh needs some ‘absolutification’, e.g. using 'substitute*',
to refer to awk, sed, tr, wc ... by their absolute path instead of using
whatever is in the profile.

Some script in ‘colorscripts’ may need changes as well

> +  (synopsis "Collection of terminal color scripts")
> +  (description "Collection of terminal color scripts")
> +  (home-page "https://gitlab.com/dwt1/shell-color-scripts")
> +  (license license:expat))) ; MIT

"; MIT" isn't necessary, as license:expat is unambigious,
whereas MIT is sometimes used for the X11 license and can theoretically
refer to any license ever used by MIT.  (Though in practice ‘the MIT license’
either refers to the X11 or the expat license.)

Greetings,
Maxime
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index 9377e5622b..c2028956fd 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -25,6 +25,7 @@ 
 ;;; Copyright © 2020 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
 ;;; Copyright © 2021 Raphaël Mélotte <raphael.melotte@mind.be>
+;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -45,6 +46,7 @@ 
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system cargo)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system go)
@@ -766,6 +768,36 @@  It's a terminal emulator with few dependencies, so you don't need a full GNOME
 desktop installed to have a decent terminal emulator.")
     (license license:gpl2)))

+(define-public shell-color-scripts
+ (package
+  (name "colorscript")
+  (version "3dbdfac24bb629238fdc3e1c8909e2c8577f8735") ; no tags
+  (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                   (url "https://gitlab.com/dwt1/shell-color-scripts")
+                   (commit version)))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32
+              "0lkiz6fkrqryr1vh0lh067q7hp8ba8887pkk8caipqphjswp2z16"))))
+  (build-system copy-build-system)
+  (arguments
+    `(#:install-plan '(("colorscript.sh" "bin/colorscript.sh")
+                       ("colorscripts" "colorscripts"))
+      #:phases
+      (modify-phases %standard-phases
+        (add-after 'unpack 'fix-colorscipts-location
+          (lambda* (#:key outputs #:allow-other-keys)
+            (substitute* "colorscript.sh"
+              (("/opt/shell-color-scripts/colorscripts")
+               (string-append (assoc-ref outputs "out") "/colorscripts"))))))))
+  (inputs `(("ncurses" ,ncurses)))
+  (synopsis "Collection of terminal color scripts")
+  (description "Collection of terminal color scripts")
+  (home-page "https://gitlab.com/dwt1/shell-color-scripts")
+  (license license:expat))) ; MIT
+
 (define-public go-github.com-nsf-termbox-go
   (let ((commit "288510b9734e30e7966ec2f22b87c5f8e67345e3")
         (revision "1"))