diff mbox series

[bug#49619,v3,1/2] gnu: Add python-very-pretty-table.

Message ID ixy1HtzUo9-aHVUDiGsmrv4eo6ujfqKN3bdVhgPAZRsXySRs1eUKkvl1wQcPI3wzv_FlTMcc8-tvTMZFjHFowaKdNDR-QRYS9bIyMyuPH8Q=@protonmail.com
State New
Headers show
Series [bug#49619,v3,1/2] gnu: Add python-very-pretty-table. | expand

Commit Message

phodina Sept. 18, 2021, 12:44 p.m. UTC
Hi Sarah,

here are some the changes for upstreaming :-)

--8<---------------cut here---------------start------------->8--

* gnu/packages/python-xyz.scm (python-very-pretty-table): New variable.

--
2.32.0
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 66857b31b0..c4fb6edd40 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1793,6 +1793,30 @@  helpers.")
     (properties `((python2-variant . ,(delay python2-humanfriendly))))
     (license license:expat)))

+(define-public python-very-pretty-table
+  (package
+    (name "python-very-pretty-table")
+    (version "0.8.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "veryprettytable" version))
+       (sha256
+        (base32
+         "1k1rifz8x6qcicmx2is9vgxcj0qb2f5pvzrp7zhmvbmci3yack3f"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-colorama" ,python-colorama)
+       ("python-termcolor" ,python-termcolor)))
+    (home-page
+     "https://github.com/smeggingsmegger/VeryPrettyTable")
+    (synopsis
+     "Visually appealing ASCII table output format")
+    (description
+     "Functions and classes in @code{very-pretty-table} allow for easily
+      displaying tabular data in a visually appealing ASCII table format.")
+    (license license:bsd-3)))
+
 (define-public python2-humanfriendly
   (let ((base (package-with-python2
                 (strip-python2-variant python-humanfriendly))))