diff mbox series

[bug#38742] gnu: python-fonttools: Update to 4.2.2

Message ID iS8eIDLTs0T7PFq_qgYCZqjE-vo4A7I8hXGK3UB5TlBHiV6E6U2IKoCNYPNPf9fXUwmFQuIMrnVtt_UMVLrsHBaLW6lGVnfz3Llalg5w3MM=@protonmail.com
State Accepted
Headers show
Series [bug#38742] gnu: python-fonttools: Update to 4.2.2 | expand

Commit Message

ashish.is--- via Guix-patches" via Dec. 25, 2019, 2:24 p.m. UTC
This updates python-fonttools to the newest version (4.2.2).
python2-fonttools is only updated to 3.44.0, as the 4.x versions don't support Python 2.

* gnu/packages/python-xyz.scm (python-fonttools): Update to 4.2.2.
* gnu/packages/python-xyz.scm (python2-fonttools): Update to 3.44.0.
---
 gnu/packages/python-xyz.scm | 18 +++++++++++++-----
 1 file changed, 13 insertions(+), 5 deletions(-)
--
2.24.0

Comments

Danny Milosavljevic Dec. 26, 2019, 11:58 a.m. UTC | #1
Hi,

thanks for the patch!  I have a few comments below:

* I can't apply it.  There's two parts in your message:
  (1) A rfc822 format file with MIME escape parts (like "=C2=A0") in it which "git am" cannot use and which looks very unusable.
  (2) A plain text format file (much better) which is missing the author information ("From"...)--so "git am" cannot use it.
  If that's a problem with our Guix-patches tooling (or my mail client), I apologize, but even with manual editing I could not apply (2).  (1) is out of the question.
  Please use "git format-patch -1" after committing the change to your local git repository in order to create the patch.
  You can revert your patch using "git reset HEAD~1" and then try "git am your-patchfile" on your side to see whether we would be able to apply it.
* Please rename the procedure from "python-fonttools-version" to "python-fonttools-package" for consistency with other places we do that.
* Please mention the new procedure in the commit log.
* Please put maintainer comments into the source code, not the commit log.
* A comment trailing a scheme line should have only one ";".

> +    (python-fonttools-version

python-fonttools-package

> +      "3.44.0"  ;; last version to support Python 2

+      "3.44.0"  ; last version to support Python 2
Marius Bakke Dec. 26, 2019, 3:05 p.m. UTC | #2
Riku Viitanen via Guix-patches via <guix-patches@gnu.org> writes:

> This updates python-fonttools to the newest version (4.2.2).
> python2-fonttools is only updated to 3.44.0, as the 4.x versions don't support Python 2.
>
> * gnu/packages/python-xyz.scm (python-fonttools): Update to 4.2.2.
> * gnu/packages/python-xyz.scm (python2-fonttools): Update to 3.44.0.

Thanks for the patch!  Note that python-fonttools has 4481 dependent
packages according to 'guix refresh -l python-fonttools', so this change
must go through the 'core-updates' branch.

We already have python-fonttools version 4.2.0 on that branch, so this
patch needs to be adjusted a little.  Can you rebase this on the
'core-updates' branch and send an updated patch?

TIA,
Marius
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c06c2199de..4d6dd7b32d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -68,6 +68,7 @@ 
 ;;; Copyright © 2019 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2019 Riku Viitanen <riku.viitanen@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6803,16 +6804,15 @@  add functionality and customization to your projects with their own plugins.")
 (define-public python2-straight-plugin
   (package-with-python2 python-straight-plugin))
 
-(define-public python-fonttools
+(define (python-fonttools-version version hash)
   (package
     (name "python-fonttools")
-    (version "3.38.0")
+    (version version)
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "fonttools" version ".zip"))
               (sha256
-               (base32
-                "12ripk3s7skgxr1bs9r8n13r94ym3s8iir7ivfixls9fa4dabmlh"))))
+               (base32 hash))))
     (build-system python-build-system)
     (native-inputs
      `(("unzip" ,unzip)
@@ -6828,8 +6828,16 @@  also contains a tool called “TTX” which converts TrueType/OpenType fonts to
 from an XML-based format.")
     (license license:expat)))
 
+(define-public python-fonttools
+  (python-fonttools-version
+    "4.2.2"
+    "012qqspnwdl4vy8qgzzpfglkk5dgzxiw0fak2jq74ngygvz3vfv6"))
+
 (define-public python2-fonttools
-  (package-with-python2 python-fonttools))
+  (package-with-python2
+    (python-fonttools-version
+      "3.44.0"  ;; last version to support Python 2
+      "0v6399g755f2hn1ry62i5b6gdinf2fpx2966v3bxh6bjw1accb5p")))
 
 (define-public python-ly
   (package