diff mbox series

[bug#55348] gnu: Add embedded-controller-hx20.

Message ID hkArDpBVH_rMN8Az9OXMvoqup47IIXE3Clr0XELDWqHK9CIl4pkCDI75-mLYiZENReIZdxJKR-LhNVYQNax92lR5BkvLp90ANzST4rqenQw=@protonmail.com
State New
Headers show
Series [bug#55348] gnu: Add embedded-controller-hx20. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina May 10, 2022, 10:28 a.m. UTC
Hi,

here's a patch that brings firmware for the Embedded Controller on Framework laptops.

I wanted to put this package into gnu/packages/firmware.scm but due to arm-none-eabi toolchain and the usage of embedded.scm module the build generates only errors due to inclusion. Therefore I temporarily placed the package to gnu/packages/embedded.scm.

I'm unfortunately not an owner of Framework laptop so I can't test the built firmware. I also don't want to ask people to reflash the EC as incorrectly built binary can result in a bricked computer.

Therefore I'd like to open the discussion what should be the steps to include EC [1][2] in general into Guix so that more parts of the firmware will be open source where possible.

[1] https://chromium.googlesource.com/chromiumos/platform/ec/https://github.com/system76/ec[2] https://github.com/system76/ec
----
Petr

Comments

M May 10, 2022, 12:52 p.m. UTC | #1
phodina via Guix-patches via schreef op di 10-05-2022 om 10:28 [+0000]:
> +	   #:make-flags '("BOARD=hx20" "CROSS_COMPILE=arm-none-eabi-
> ")
> +	   #:phases
> +       (modify-phases %standard-phases
> +         (delete 'configure)
> +         (delete 'install))))
> +    (native-inputs (list arm-none-eabi-toolchain-7-2018-q2-update

Maybe we can use Guix cross-compilation mechanism here:

(arguments
  (list #:target "arm-none-eabi"
        #:cross-implicit-inputs? #false ; custom gcc required because
        [...]))
(native-inputs (list ...)

Also, why are 'libftdi, inetutils, ...' in inputs?  Do they end up in
the firmware somehow?  Or does embedded-controller-hx20 not only
contain firmware but also some kind of binaries to control the firmware
or such?  If the latter, I don't think #:target can be used here.

Gree
M May 10, 2022, 12:54 p.m. UTC | #2
phodina via Guix-patches via schreef op di 10-05-2022 om 10:28 [+0000]:
> Modifying the EC code
> +can cause your system to not power on or boot or cause damage to the
> mainboard,

Maybe a qualifier ‘Modifying the EC code incorrectly’?  Also maybe the
loss of warranty mentioned in the README?

Greetings,
Maxime.
Ludovic Courtès June 17, 2022, 8:38 p.m. UTC | #3
Hi phodina,

phodina <phodina@protonmail.com> skribis:

> From eb4dcfad9ad9126941acc0ba9522bbaa9d856fdf Mon Sep 17 00:00:00 2001
> From: Petr Hodina <phodina@protonmail.com>
> Date: Fri, 28 Jan 2022 19:29:56 +0100
> Subject: [PATCH] gnu: Add embedded-controller-hx20.
>
> * gnu/packages/embedded.scm (embedded-controller-hx20): New variable.

Did you have a chance to look into addressing Maxime’s comments?

  https://issues.guix.gnu.org/55348

TIA,
Ludo’.
phodina June 18, 2022, 4:49 a.m. UTC | #4
Hi Ludo’,

> Did you have a chance to look into addressing Maxime’s comments?
> https://issues.guix.gnu.org/55348

not yet, but I plan to do so next week.

----
Petr
diff mbox series

Patch

From eb4dcfad9ad9126941acc0ba9522bbaa9d856fdf Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Fri, 28 Jan 2022 19:29:56 +0100
Subject: [PATCH] gnu: Add embedded-controller-hx20.

* gnu/packages/embedded.scm (embedded-controller-hx20): New variable.

diff --git a/gnu/packages/embedded.scm b/gnu/packages/embedded.scm
index de8d2944bc..8b5dd99dc8 100644
--- a/gnu/packages/embedded.scm
+++ b/gnu/packages/embedded.scm
@@ -70,6 +70,42 @@  (define-module (gnu packages embedded)
   #:use-module (gnu packages xorg)
   #:use-module (srfi srfi-1))
 
+
+(define-public embedded-controller-hx20
+(let ((commit "8109392adb17a2cd7d30a74eee8613a0cb72ee7d")
+      (revision "1"))
+  (package
+    (name "embedded-controller-hx20")
+    (version (git-version "0.1" revision commit))
+    (source
+	(origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/FrameworkComputer/EmbeddedController")
+                    (commit commit)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "16y6v886ci97yxn8q54iwm9clx0kgvszrxp5vjh0hdldc9pamaij"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f
+	   #:make-flags '("BOARD=hx20" "CROSS_COMPILE=arm-none-eabi-")
+	   #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)
+         (delete 'install))))
+    (native-inputs (list arm-none-eabi-toolchain-7-2018-q2-update
+	base:coreutils
+	perl pkg-config python python-2))
+    (inputs (list libftdi inetutils inetutils libusb))
+    (synopsis "Embedded Controller firmware for the Framework Laptop")
+    (description "The Embedded Controller on your Framework Laptop handles low
+level functions, including power sequencing the system.  Modifying the EC code
+can cause your system to not power on or boot or cause damage to the mainboard,
+battery, or other parts of the system or devices attached to the system.")
+    (home-page "https://github.com/FrameworkComputer/EmbeddedController")
+    (license license:bsd-3))))
 ;; We must not use the released GCC sources here, because the cross-compiler
 ;; does not produce working binaries.  Instead we take the very same SVN
 ;; revision from the branch that is used for a release of the "GCC ARM
-- 
2.34.0