diff mbox series

bug#54983: closed (Re: bug#55045: [PATCH] update neovim to 0.7.0)

Message ID handler.54983.D55045.165289754724188.notifdone@debbugs.gnu.org
State Accepted
Headers show
Series bug#54983: closed (Re: bug#55045: [PATCH] update neovim to 0.7.0) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

GNU bug Tracking System May 18, 2022, 6:13 p.m. UTC
Your bug report

#55045: [PATCH 2/3] gnu: lua-luv: Update to 1.43.0-0.

which was filed against the guix-patches package, has been closed.

The explanation is attached below, along with your original report.
If you require more details, please reply to 54983@debbugs.gnu.org.
diff mbox series

Patch

diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index ee4b7727e0..e91d04cbd0 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -785,7 +785,7 @@  (define-public lua5.2-lpeg
 (define (make-lua-luv name lua)
   (package
     (name name)
-    (version "1.32.0-0")
+    (version "1.43.0-0")
     (source (origin
               ;; The release tarball includes the sources of libuv but does
               ;; not include the pkg-config files.
@@ -796,7 +796,7 @@  (define (make-lua-luv name lua)
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0c65c1lhbl0axnyks3910gjs0z0hw7w6jvl07g8kbpnbvfl4qajh"))))
+                "1yzi4bm845vl84wyv2qw4z1n1v285lgwm681swmp84brfy2s7czp"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f                      ; there are none
@@ -813,7 +813,7 @@  (define (make-lua-luv name lua)
              (copy-recursively (assoc-ref inputs "lua-compat")
                                "lua-compat")
              (setenv "CPATH"
-                     (string-append (getcwd) "/lua-compat:"
+                     (string-append (getcwd) "/lua-compat/c-api:"
                                     (or (getenv "CPATH") "")))
              #t)))))
     (inputs
@@ -824,11 +824,11 @@  (define (make-lua-luv name lua)
            (method git-fetch)
            (uri (git-reference
                  (url "https://github.com/keplerproject/lua-compat-5.3")
-                 (commit "daebe77a2f498817713df37f0bb316db1d82222f")))
+                 (commit "e245d3a18957e43ef902a59a72c8902e2e4435b9")))
            (file-name "lua-compat-5.3-checkout")
            (sha256
             (base32
-             "02a14nvn7aggg1yikj9h3dcf8aqjbxlws1bfvqbpfxv9d5phnrpz"))))))
+             "1caxn228gx48g6kymp9w7kczgxcg0v0cd5ixsx8viybzkd60dcn4"))))))
     (home-page "https://github.com/luvit/luv/")
     (synopsis "Libuv bindings for Lua")
     (description