diff mbox series

[bug#57578] gnu: Add emacs-buffer-env.

Message ID ha0ui6cyhF2DIXBioGP87M1n83ctS_zf5Wg_2J8yEmKR5x6PIRUOCiXVJGrNUwvMATQyA1MIA0CuZOXMAed8vAI_KUpFG21pAnmp-w7MZSA=@protonmail.com
State Accepted
Headers show
Series [bug#57578] gnu: Add emacs-buffer-env. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

rdes Sept. 4, 2022, 2:32 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-buffer-env): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

--
2.34.4

Comments

Nicolas Goaziou Sept. 4, 2022, 6:35 p.m. UTC | #1
Hello,

rdes via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-buffer-env): New variable.

Thank you. However the package already exists in Guix.

I'm closing the bug report.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6d89104226..e2740e4cc9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -32488,3 +32488,25 @@  a way to pop up a frame at point.  Vertico-posframe is an Emacs package and
 a Vertico extension which provides a way to pop up a frame at point to show
 a vertical completion UI.")
     (license license:gpl3+)))
+
+(define-public emacs-buffer-env
+  (package
+    (name "emacs-buffer-env")
+    (version "0.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://elpa.gnu.org/packages/buffer-env-"
+                                  version ".tar"))
+              (sha256
+               (base32
+                "0y8ik87dqldhn6q631zp2ln9z5byqgm9icrvr4xrdx6g8mr9c56z"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-compat))
+    (home-page "https://github.com/astoff/buffer-env")
+    (synopsis "Buffer-local process environments")
+    (description
+     "With this package, you can teach Emacs to call the correct version of external
+programs such as linters, compilers and language servers on a /per-project/
+basis.  Thus you can work on several projects in parallel with no undue
+interference and switch seamlessly between them.")
+    (license license:gpl3+)))