[bug#35193,1/3] Add python-typed-ast

Message ID hL9Eqz5ZF52qkUkWX3OiX156-pQOztKX1Oq5cZuhJsYQvSm6FBiDf4_MWuLutrYQjxAasR9wcgQUF6s0y-LM-ucT5ICeGdi2cFYy1DRLbZM=@protonmail.com
State Accepted
Headers show
Series Add python-mypy and required packages | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

JesseJohnGildersleve April 8, 2019, 2:20 p.m. UTC
From ad2b363f11805002bee96d1471bff8471c0a1711 Mon Sep 17 00:00:00 2001
From: frozenpigs <purpjuice@protonmail.com>
Date: Mon, 8 Apr 2019 14:34:19 +0100
Subject: [PATCH 1/3] gnu: add python-typed-ast

---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

--
2.21.0

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 014026d06e..b5bfd6a261 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -59,6 +59,7 @@ 
 ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
 ;;; Copyright © 2019 Sam <smbaines8@gmail.com>
+;;; Copyright © 2019 Jesse Gildersleve <jessejohngildersleve@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -15319,3 +15320,25 @@  processes may share the same data.")
     (description "A Sphinx extension to convert SVG images to PDF in case the builder does not support
 SVG images natively (e.g. LaTeX).")
     (license license:bsd-3)))
+
+(define-public python-typed-ast
+  (package
+    (name "python-typed-ast")
+    (version "1.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "typed-ast" version))
+       (sha256
+        (base32
+         "095l1jfxk1k2z5sijbirg2s5a01r4ig3715zqa075xzf0zx8lvb0"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/python/typed_ast")
+    (synopsis "Fork of Python 2 and 3 ast modules with type comment support")
+    (description "Typed_ast is a Python 3 package that provides a Python 2.7 and
+Python 3 parser similar to the standard ast library.  Unlike ast, the parsers in
+typed_ast include PEP 484 type comments and are independent of the version of Python
+under which they are run.  The typed_ast parsers produce the standard Python AST
+(plus type comments), and are both fast and correct, as they are based on the
+CPython 2.7 and 3.6 parsers.")
+    (license license:asl2.0)))