diff mbox series

[bug#46686] gnu: add libucl

Message ID h7NfSSBWXKgCk4KXIid6eBO4hUAtZfaVRlalkRTyiBp6dUlwxLm3xJMj3rWtGQEPu7jyU6g3X5EL9eJNNp32LHvOX-GDBiJPik7vDgJqzXI=@protonmail.com
State Accepted
Headers show
Series [bug#46686] gnu: add libucl | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

qblade Feb. 21, 2021, 7:21 a.m. UTC
Empty Message

Comments

Ludovic Courtès March 6, 2021, 10:32 a.m. UTC | #1
Hi,

qblade <qblade@protonmail.com> skribis:

> From aae95593f1cfd48c50578bec83927c870afc6bce Mon Sep 17 00:00:00 2001
> From: qblade <qblade@protonmail.com>
> Date: Sun, 21 Feb 2021 06:48:18 +0000
> Subject: [PATCH] gnu: add libucl
>
> * gnu/packages/config-lang.scm (libucl): New variable.

Thanks for the patch!  It looks good to me, modulo the minor issues
below.

>  gnu/packages/config-lang.scm | 54 ++++++++++++++++++++++++++++++++++++

Could you perhaps find another file to add it to, so we don’t have a
module for a single package?  That said, I don’t have a good suggestion,
since ‘iniparser’ for instance is in samba.scm.

> +    (synopsis "Universal configuration language")
> +    (description "Universal configuration language.
> +fully compatible with JSON format and is able to parse json files")

Could you reword the description with full sentences, along the lines of:

  https://guix.gnu.org/manual/en/html_node/Synopses-and-Descriptions.html

Make sure to capitalize acronyms like JSON.

TIA,
Ludo’.
diff mbox series

Patch

From aae95593f1cfd48c50578bec83927c870afc6bce Mon Sep 17 00:00:00 2001
From: qblade <qblade@protonmail.com>
Date: Sun, 21 Feb 2021 06:48:18 +0000
Subject: [PATCH] gnu: add libucl

* gnu/packages/config-lang.scm (libucl): New variable.
---
 gnu/packages/config-lang.scm | 54 ++++++++++++++++++++++++++++++++++++
 1 file changed, 54 insertions(+)
 create mode 100644 gnu/packages/config-lang.scm

diff --git a/gnu/packages/config-lang.scm b/gnu/packages/config-lang.scm
new file mode 100644
index 0000000000..8ef0b1cdb6
--- /dev/null
+++ b/gnu/packages/config-lang.scm
@@ -0,0 +1,54 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 qblade <qblade@protonmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages config-lang)
+  #:use-module (gnu packages)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (guix build-system gnu)
+  #:use-module (guix git-download))
+
+(define-public libucl
+  (package
+    (name "libucl")
+    (version "0.8.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/vstakhov/libucl/")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1h52ldxankyhbbm1qbqz1f2q0j03c1b4mig7343bs3mc6fpm18gf"))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)
+       ("libtool" ,libtool)))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f)) ;; no tests
+    (home-page "https://github.com/vstakhov/libucl")
+    (synopsis "Universal configuration language")
+    (description "Universal configuration language.
+fully compatible with JSON format and is able to parse json files")
+    (license license:bsd-2)))
-- 
2.29.2