diff mbox series

[bug#51739,1/3] gnu: Add realmd.

Message ID g_5R9XgrFP88hXidoVzejCexj0QalG24N7Gh4dBAyDUveQAMfiRMVs7Mn7pcqDuPkOjsgsLyEiWgO0_zY2XONA1xg1hEZEVk6OH7_j1o8bY=@protonmail.com
State Accepted
Headers show
Series [bug#51739,1/3] gnu: Add realmd. | expand

Commit Message

phodina Dec. 3, 2021, 2:17 p.m. UTC
Hi Leo,

here's an updated comment.

----
Petr

Comments

Leo Famulari Dec. 8, 2021, 7:27 p.m. UTC | #1
On Fri, Dec 03, 2021 at 02:17:49PM +0000, phodina via Guix-patches via wrote:
> Hi Leo,
> 
> here's an updated comment.

Thank you! I tweaked the comment to make it more idiomatic, added you to
the list of authors of gnu/packages/admin.scm, and pushed as
0ba4e94e8448e6c27cceb690b085c8d8cf66e577.
diff mbox series

Patch

From c630ef52f780d22e7defbea308e805f0a513858b Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Wed, 10 Nov 2021 03:53:37 +0100
Subject: [PATCH v3] gnu: Add realmd.

* gnu/packages/admin.scm (realmd): New variable.

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index d24b068bd7..b32f7e29f6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -128,6 +128,7 @@  (define-module (gnu packages admin)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages perl-check)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages polkit)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-crypto)
@@ -1533,6 +1534,56 @@  (define-public clusterssh
 over ssh connections.")
     (license license:gpl2+)))
 
+(define-public realmd
+  (package
+    (name "realmd")
+    (version "0.17.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/freedesktop/realmd")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1c6q2a86kk2f1akzc36nh52hfwsmmc0mbp6ayyjxj4zsyk9zx5bf"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:configure-flags '("--with-systemd-unit-dir=no"
+                           "--with-systemd-journal=no"
+                           "--with-distro=GNU guix"
+                           "--disable-doc")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'fix-service
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; GNU Guix does not have service config file, therefore we empty
+             ;; the line where we copy the file
+             (substitute* "Makefile"
+               ((".*/service/realmd-.*") "")))))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("glib-bin" ,glib "bin")
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python)))
+    (inputs
+     `(("glib" ,glib)
+       ("mit-krb5" ,mit-krb5)
+       ("openldap" ,openldap)
+       ("polkit" ,polkit)))
+    (synopsis "DBus service for network authentication")
+    (description "This package provides an on demand system DBus service.
+It allows callers to configure network authentication and domain membership
+in a standard way.  Realmd discovers information about the domain or realm
+automatically and does not require complicated configuration in order to join
+a domain or realm.  Dbus system service that manages discovery and enrollment in
+realms/domains like Active Directory or IPA.")
+    (home-page "https://www.freedesktop.org/software/realmd/")
+    (license license:lgpl2.1+)))
+
 (define-public rename
   (package
     (name "rename")
-- 
2.33.1