diff mbox series

[bug#41288] gnu: Add lib3ds.

Message ID gNbjeEKOwFwMRSHcVk4-ZhNjpJN0HX28-TjO7m3jAGGF8cJR-UeCqBPk1PdWRypivx8zS9bZOX6V2SVRxRvp4CeQLFZCMvWhKgUwtNJxI3o=@elenq.tech
State Accepted
Headers show
Series [bug#41288] gnu: Add lib3ds. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ekaitz Zarraga May 15, 2020, 2:12 p.m. UTC
Hi,

Added lib3ds as discussed here:

https://issues.guix.gnu.org/40492

I think everything is fine in the package but in building there are some messages about ldconfig not being available as we don't have it in guix. I checked that everything was installed correctly and it is but I'm not sure if that's going to have any other effect I didn't consider.

Thanks,
Ekaitz

From d295cb56c8ffa7df6a75ef9e97c6ba364d493405 Mon Sep 17 00:00:00 2001
From: Ekaitz Zarraga <ekaitz@elenq.tech>
Date: Fri, 15 May 2020 16:05:11 +0200
Subject: [PATCH] gnu: Add lib3ds.

    * gnu/packages/engineering.scm (lib3ds): New variable.
---
 gnu/packages/engineering.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

--
2.26.1
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 172f8481eb..5d0fca030a 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2533,3 +2533,26 @@  without any changes.  And programmers that are familiar with the magellan API
 can continue using it with a free library without the restrictions of the
 official SDK.")
     (license license:bsd-3)))
+
+(define-public lib3ds
+  (let ((version "1.3.0"))
+    (package
+      (name "lib3ds")
+      (version version)
+      (source
+       (origin
+         (method url-fetch)
+         (uri (string-append
+               "https://storage.googleapis.com/google-code-archive-downloads"
+               "/v2/code.google.com/lib3ds/lib3ds-" version ".zip"))
+         (sha256
+          (base32 "1qr9arfdkjf7q11xhvxwzmhxqz3nhcjkyb8zzfjpz9jm54q0rc7m"))))
+      (build-system gnu-build-system)
+      (native-inputs
+       `(("unzip" ,unzip)))
+      (home-page "http://lib3ds.sourceforge.net")
+      (synopsis "3DS format file toolkit")
+      (description "Lib3ds is a toolkit for handling the 3DS format for 3D
+model files.  Its main goal is to simplify the creation of 3DS import and
+export filters.")
+      (license license:lgpl3+))))