diff mbox series

[bug#57944,1/2] gnu: Add gnome-text-editor

Message ID g-cXXPJW84tFhm3bAFXfktP0mcRz2IM47eOtQaq0fjiVADA5sqcYfIlFiLfJzdjNSVZ1VwxkSeKi2SoVGfC2tvplzia1dlrQiuQWCotpgqw=@proton.me
State Accepted
Headers show
Series [bug#57944,1/2] gnu: Add gnome-text-editor | expand

Commit Message

Sughosha Sept. 20, 2022, 11:21 a.m. UTC
One more small correction, cmake as native-input was not necessary.

Comments

Liliana Marie Prikler Sept. 21, 2022, 6:22 p.m. UTC | #1
Am Dienstag, dem 20.09.2022 um 11:21 +0000 schrieb Sughosha:
> One more small correction, cmake as native-input was not necessary.
You probably saw this already, but I pushed this series with the
nautilus extension to gnome-console.

Cheers
diff mbox series

Patch

From 8142d2bc994e1b7cc61ad379f9ce13ee7e274ec0 Mon Sep 17 00:00:00 2001
From: Sughosha <sughosha@proton.me>
Date: Tue, 20 Sep 2022 06:08:05 +0200
Subject: [PATCH 2/2] gnu: Add gnome-console

* gnu/packages/gnome.scm (gnome-console): New variable.
---
 gnu/packages/gnome.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c76b25d968..14e9c36fc6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5411,6 +5411,38 @@  (define-public gnome-sudoku
 more fun.")
     (license license:gpl2+)))
 
+(define-public gnome-console
+  (package
+    (name "gnome-console")
+    (version "42.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/gnome-console/"
+                                  (version-major version) "/"
+                                  "gnome-console-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0jbh8g3hmc35fy5fbscqf0831xpg1kv66ci9hykpbia4hz0yc9kx"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t
+       #:configure-flags
+       `("-Dtests=true")))
+    (native-inputs (list `(,glib "bin")
+                         gettext-minimal
+                         sassc
+                         pkg-config
+                         `(,gtk+ "bin")
+                         desktop-file-utils))
+    (inputs (list gtk+
+                  libhandy
+                  vte
+                  libgtop
+                  gsettings-desktop-schemas))
+    (home-page "https://gitlab.gnome.org/GNOME/console")
+    (synopsis "GNOME terminal emulator")
+    (description
+     "Console is a simple terminal emulator for GNOME desktop")
+    (license license:gpl3+)))
+
 (define-public gnome-terminal
   (package
     (name "gnome-terminal")
-- 
2.37.3