diff mbox series

[bug#60053] gnu: Add pdfcrack.

Message ID ftPPvLrQVmX2f8WUFJVME78-0e8PPqCvb3r21w6DSr7xfTG6KHWV_C4Gf6VbsqM0Mis1-MEHiSBmvqRb7bgSgpYqMzzNe6XTcIRkLHQaQb0=@protonmail.com
State New
Headers show
Series [bug#60053] gnu: Add pdfcrack. | expand

Commit Message

phodina Dec. 13, 2022, 11:58 p.m. UTC
Hello,

here's another Kali tool in case you forget password for PDF file.

----
Petr

Comments

Nicolas Goaziou Jan. 3, 2023, 2:12 p.m. UTC | #1
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> here's another Kali tool in case you forget password for PDF file.

It looks like I forgot to close this one.

I applied your patch a couple of weeks ago. Thank you!

Regards,
diff mbox series

Patch

From a856681da7868a3d6fd08469e68be23bf1bb8956 Mon Sep 17 00:00:00 2001
From: Petr Hodina <phodina@protonmail.com>
Date: Wed, 14 Dec 2022 00:56:34 +0100
Subject: [PATCH] gnu: Add pdfcrack.

* gnu/packages/pdf.scm (pdfcrack): New variable.

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 070dc59ac0..cf0268f418 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -23,6 +23,7 @@ 
 ;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
+;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1203,6 +1204,37 @@  (define-public fbida
 the framebuffer.")
     (license license:gpl2+)))
 
+(define-public pdfcrack
+  (package
+    (name "pdfcrack")
+    (version "0.20")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://salsa.debian.org/debian/pdfcrack")
+                    (commit (string-append "upstream/" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "15vrl4c14nqrcgwqqv26p73dzipy8n15d3f0pgi8mywcr5d4p33w"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:tests? #f ;no test suite
+           #:make-flags #~(list (string-append "CC="
+                                               #$(cc-for-target)))
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'configure)
+                        (replace 'install
+                          (lambda* _
+                            (mkdir-p (string-append #$output "/bin"))
+                            (install-file "pdfcrack"
+                                          (string-append #$output "/bin")))))))
+    (home-page "https://pdfcrack.sourceforge.net/")
+    (synopsis "Password Recovery Tool for PDF-files")
+    (description "This package provides a simple tool for recovering passwords
+from pdf-documents that use the standard security handler.")
+    (license license:gpl2+)))
+
 (define-public pdf2svg
   (package
     (name "pdf2svg")
-- 
2.38.1