diff mbox series

[bug#72205,1/4] gnu: Add kdsingleapplication.

Message ID ffde2cc6327776cb3372b66970242ac6c1d68884.1721458149.git.timotej.lazar@araneo.si
State New
Headers show
Series Update nheko | expand

Commit Message

Timotej Lazar July 20, 2024, 6:57 a.m. UTC
* gnu/packages/qt.scm (kdsingleapplication): New variable.

Change-Id: I08407da35712d465f9573f6bf1de0cc2e8435cb1
---
 gnu/packages/qt.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Maxim Cournoyer July 31, 2024, 6:05 a.m. UTC | #1
Hi,

(I got notified for this 1/4 patch due to touching qt.scm; I haven't
checked the rest of the series).

Timotej Lazar <timotej.lazar@araneo.si> writes:

> * gnu/packages/qt.scm (kdsingleapplication): New variable.
>
> Change-Id: I08407da35712d465f9573f6bf1de0cc2e8435cb1
> ---
>  gnu/packages/qt.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index 0138fd3dbf..c150dca78b 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -5214,6 +5214,32 @@ (define-public libdbusmenu-qt
>  and import their menus over DBus.")
>      (license license:lgpl2.1+)))
>  
> +(define-public kdsingleapplication
> +  (package
> +    (name "kdsingleapplication")
> +    (version "1.1.0")
> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://github.com/KDAB/KDSingleApplication")
> +             (commit (string-append "v" version))))
> +       (file-name (git-file-name name version))
> +       (sha256
> +        (base32 "1w7wg9w4mifrkpn7hhw1nnnwh1vhnf8i4wgfxvh44nacwslbwsb2"))))
> +    (build-system qt-build-system)
> +    (arguments
> +     (list
> +      #:qtbase qtbase
> +      #:configure-flags
> +      #~(list "-DKDSingleApplication_QT6=true" "-DKDSingleApplication_TESTS=true")))

That's a nitpick, but my impression was that ON/OFF as boolean value for
CMake were more common (or YES/NO).

> +    (inputs (list libxkbcommon vulkan-headers))
> +    (home-page "https://github.com/KDAB/KDSingleApplication")
> +    (synopsis "Qt helper class for single-instance policy applications")
> +    (description "KD SingleApplication is a helper class for single-instance
> +policy applications.")
> +    (license (list license:bsd-3 license:expat))))

Is it dual licensed? Or which files/section of the source is covered by
which? A comment is needed.
Timotej Lazar July 31, 2024, 12:28 p.m. UTC | #2
(Sending again to include the list.)

Thanks for the review! The patches have already been merged, but I’ll send another one fixing the issues you point out.

Maxim Cournoyer <maxim.cournoyer@gmail.com> [2024-07-31 15:05:21+0900]:
> Timotej Lazar <timotej.lazar@araneo.si> writes:
>> +      #:configure-flags
>> +      #~(list "-DKDSingleApplication_QT6=true" "-DKDSingleApplication_TESTS=true")))
>
> That's a nitpick, but my impression was that ON/OFF as boolean value for
> CMake were more common (or YES/NO).

I went by the build instructions¹ but I’ll change it to be consistent with (most) other packages.

>> +    (license (list license:bsd-3 license:expat))))
>
> Is it dual licensed? Or which files/section of the source is covered by
> which? A comment is needed.

No, some build files are licensed differently. I meant to add a comment but forgot.

¹ https://github.com/KDAB/KDSingleApplication/blob/1.1/INSTALL.txt
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0138fd3dbf..c150dca78b 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -5214,6 +5214,32 @@  (define-public libdbusmenu-qt
 and import their menus over DBus.")
     (license license:lgpl2.1+)))
 
+(define-public kdsingleapplication
+  (package
+    (name "kdsingleapplication")
+    (version "1.1.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/KDAB/KDSingleApplication")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1w7wg9w4mifrkpn7hhw1nnnwh1vhnf8i4wgfxvh44nacwslbwsb2"))))
+    (build-system qt-build-system)
+    (arguments
+     (list
+      #:qtbase qtbase
+      #:configure-flags
+      #~(list "-DKDSingleApplication_QT6=true" "-DKDSingleApplication_TESTS=true")))
+    (inputs (list libxkbcommon vulkan-headers))
+    (home-page "https://github.com/KDAB/KDSingleApplication")
+    (synopsis "Qt helper class for single-instance policy applications")
+    (description "KD SingleApplication is a helper class for single-instance
+policy applications.")
+    (license (list license:bsd-3 license:expat))))
+
 (define-public kdsoap
   (package
     (name "kdsoap")