diff mbox series

[bug#57757] gnu: Add sbcl-stumpwm-pamixer

Message ID ffcb7e876354b99698a9d0866ed4337a00678ac8.1663273983.git.trev@trevdev.ca
State Accepted
Headers show
Series [bug#57757] gnu: Add sbcl-stumpwm-pamixer | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Trevor Richards Sept. 12, 2022, 9:41 p.m. UTC
---
 gnu/packages/wm.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Guillaume Le Vaillant Sept. 16, 2022, 7:50 a.m. UTC | #1
Trevor Richards <trev@trevdev.ca> skribis:

> ---
>  gnu/packages/wm.scm | 25 +++++++++++++++++++++++++
>  1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 451dfce516..3f2258db52 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -1986,6 +1986,31 @@ (define-public stumpish
>      (description "This package provides a StumpWM interactive shell.")
>      (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
>  
> +(define-public sbcl-stumpwm-pamixer
> [...]
> +      (inputs `(("stumpwm" ,stumpwm "lib")))
> +      (propagated-inputs (list pamixer))
> [...]

Hi.

Instead of propagating pamixer, it would be better to put pamixer in
'inputs' and fix the path to the pamixer program in the 'run' function
in "pamixer.lisp". For example, take a look at the 'fix-paths' phase of
the sbcl-trivial-clipboard package.

Could you send an updated patch?
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 451dfce516..3f2258db52 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -1986,6 +1986,31 @@  (define-public stumpish
     (description "This package provides a StumpWM interactive shell.")
     (license (list license:gpl2+ license:gpl3+ license:bsd-2))))
 
+(define-public sbcl-stumpwm-pamixer
+  (let ((commit "aa820533c80ea1af5a0e107cea25eaf34e69dc24")
+        (revision "1"))
+    (package
+      (name "sbcl-stumpwm-pamixer")
+      (version (git-version "0.1.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/Junker/stumpwm-pamixer.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0djcrr16bx40l7b60d4j507vk5l42fdgmjpgrnk86z1ba8wlqim8"))))
+      (inputs `(("stumpwm" ,stumpwm "lib")))
+      (propagated-inputs (list pamixer))
+      (build-system asdf-build-system/sbcl)
+      (arguments '(#:asd-systems '(:pamixer)))
+      (home-page "https://github.com/Junker/stumpwm-pamixer")
+      (synopsis "StumpWM Pamixer Module")
+      (description "Minimalistic Pulseaudio volume and microphone control
+module for StumpWM.")
+      (license license:gpl3))))
+
 (define-public sbcl-stumpwm+slynk
   (deprecated-package "sbcl-stumpwm-with-slynk" stumpwm+slynk))