@@ -727,6 +727,39 @@ (define-public facter
(home-page "https://github.com/puppetlabs/facter")
(license license:expat)))
+(define-public perp
+ (package
+ (name "perp")
+ (version "2.07")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "http://b0llix.net/perp/distfiles/perp-" version ".tar.gz"))
+ (sha256
+ (base32 "05aq8xj9fpgs468dq6iqpkfixhzqm4xzj5l4lyrdh530q4qzw8hj"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f ;no tests
+ #:make-flags
+ #~(list
+ "BINDIR = /bin"
+ "SBINDIR = /sbin"
+ "MANDIR = /share/man"
+ (string-append "DESTDIR=" #$output))
+ #:phases #~(modify-phases %standard-phases (delete 'configure))))
+ (home-page "http://b0llix.net/perp/")
+ (synopsis "Persistent process supervisor and service managment framework")
+ (description
+ "The perp package provides a set of daemons and utilities to reliably
+start, monitor, log, and control a collection of persistent processes. It is
+portable across a wide variety of unix-like operating systems. It does not
+replace the Process 1 (/sbin/init).")
+ (license
+ (license:fsdg-compatible "http://b0llix.net/perp/site.cgi?page=LICENSE"))))
+
(define-public ttyload
(let ((revision "1")
(commit "f9495372801ce4b4dad98ad854203e694c31c1eb"))
* gnu/packages/admin.scm (perp): New variable. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org> Change-Id: I6a20a7f1f7103eeea980612a046531d556192356 --- gnu/packages/admin.scm | 33 +++++++++++++++++++++++++++++++++ 1 file changed, 33 insertions(+)