diff mbox series

[bug#71984,python-team] gnu: python-pygments: Update to 2.18.0.

Message ID ff408ae39ce3d8311a087dc17fb574dbbccbed34.1720377247.git.felgru@posteo.net
State New
Headers show
Series [bug#71984,python-team] gnu: python-pygments: Update to 2.18.0. | expand

Commit Message

Felix Gruber July 7, 2024, 6:34 p.m. UTC
* gnu/packages/python-xyz.scm (python-pygments): Update to 2.18.0.
[source]: Fix pypi package name; with capital P, the download doesn't
work.
[native-inputs]: Remove python-setuptools and python-wheel;
add python-hatchling.

Change-Id: I85bf3cb2a8c4a996586e820bd582dea777ef930d
---
 gnu/packages/python-xyz.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: e4ad2f178af65be6c8ca6e98a667787674cd8c82

Comments

jgart July 8, 2024, 3:18 p.m. UTC | #1
Hi Felix,

This patch is empty according to `mumi am -- -s -S`.

Did you send this patch with git send-email or by some other means like
email attachment?

Just trying to understand why this failed.
Felix Gruber July 8, 2024, 4:20 p.m. UTC | #2
Hi jgart,

On 7/8/24 5:18 PM, jgart wrote:
> This patch is empty according to `mumi am -- -s -S`.
> 
> Did you send this patch with git send-email or by some other means like
> email attachment?
> 
> Just trying to understand why this failed.

That's weird. I generated the patch with git send-email from a commit 
that I had on top of the python-team branch.
If I download my email as .mbox from https://issues.guix.gnu.org/71984 
via the "Download raw message" button, I'm able to apply it on top of 
the python-team branch with git am.

I never tried mumi. I wonder what it does differently from git am.

Kind regards,
Felix
jgart July 8, 2024, 4:46 p.m. UTC | #3
Hi Felix,

Oops my fault, I was trying to apply this on master. 🦆

Can you rebase this patch on the master branch? I can review it there. 

The python-team branch is already overloaded, stale, and requires a ton of merge conflict resolving.

Adding python-pygments to the python-team branch will only add to that 🙃

Can you also CC Sharlatan, and ask Sharlatan to try building all the dependents that this patch triggers? 

Sharlatan Hellseher <sharlatanus@gmail.com>

I won't be able to test that on my old Thinkpad X230 machine.

all the best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30b84d284d..33bb2ef599 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7125,14 +7125,14 @@  (define-public python-doc8
 (define-public python-pygments
   (package
     (name "python-pygments")
-    (version "2.15.1")
+    (version "2.18.0")
     (source
      (origin
        (method url-fetch)
-       (uri (pypi-uri "Pygments" version))
+       (uri (pypi-uri "pygments" version))
        (sha256
         (base32
-         "0p3p28fif7m2w5mkd0z99zk9xwgrs3m61x85415qk0fl3ly4vkla"))))
+         "16gi0i80rbk0dnxka9wzx5gm10bfm3lzd29qzwdk349fyc1ghvvq"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -7141,7 +7141,7 @@  (define-public python-pygments
       ;; basic tests.
       '(list "--ignore-glob=tests/*/*")))
     (native-inputs
-     (list python-pytest python-setuptools python-wheel))
+     (list python-hatchling python-pytest))
     (home-page "https://pygments.org/")
     (synopsis "Syntax highlighting")
     (description