[bug#75032,02/13] gnu: Add sagemath-data-polytopes-db.

Message ID ff38822d5d2c0e62deb24dc867753e1359d4b183.1734887844.git.monego@posteo.net
State New
Headers
Series Add more SageMath packages |

Commit Message

Vinicius Monego Dec. 22, 2024, 5:26 p.m. UTC
  From: vicvbcun <guix@ikherbers.com>

* gnu/packages/sagemath.scm (sagemath-data-polytopes-db): New variable.

Change-Id: I8dd6cbd0b71a01d817486882bec8f126dece7e36
Co-authored by: Vinicius Monego <monego@posteo.net>

Change-Id: Iada71a7939e5deadf6888af6c21621e5458622d1
---
 gnu/packages/sagemath.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)
  

Patch

diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 734aabf739..1fefb26e36 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -23,6 +23,7 @@ 
 
 (define-module (gnu packages sagemath)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system pyproject)
   #:use-module (guix build-system python)
@@ -402,3 +403,25 @@  (define-public sagemath-data-conway-polynomials
 polynomials.  The aim of this package is to make them available through a
 generic Python interface.")
     (license license:gpl3+)))
+
+(define-public sagemath-data-polytopes-db
+  (package
+    (name "sagemath-data-polytopes-db")
+    (version "20170220")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://mirrors.mit.edu/sage/spkg/upstream/polytopes_db"
+                    "/polytopes_db-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1q0cd811ilhax4dsj9y5p7z8prlalqr7k9mzq178c03frbgqny6b"))))
+    (build-system copy-build-system)
+    (arguments '(#:install-plan '(("." "share/reflexive_polytopes"))))
+    (home-page "https://www.sagemath.org")
+    (synopsis "Lists of 2- and 3-dimensional reflexive polytopes")
+    (description
+     "This package contains data for 2- and 3-dimensional reflexive polytopes
+to be used by SageMath.")
+    ;; Debian says GPLv2+.
+    (license license:gpl2+)))