diff mbox series

[bug#56202,v5] gnu: Add nsync

Message ID ff2a1864eff1733af6f72bca069f0a52f45e06f2.1690520012.git.atai@atai.org
State New
Headers show
Series [bug#56202,v5] gnu: Add nsync | expand

Commit Message

Andy Tai July 28, 2023, 4:54 a.m. UTC
* gnu/packages/c.scm (nsync): New variable.
---
 gnu/packages/c.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 35c8d631d2bd63c64e863b5509f29fdcb7f856e6
diff mbox series

Patch

diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 9e5b511b98..722e2844cb 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -19,6 +19,7 @@ 
 ;;; Copyright © 2022 ( <paren@disroot.org>
 ;;; Copyright © 2023 zamfofex <zamfofex@twdb.moe>
 ;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1495,6 +1496,34 @@  (define-public utest-h
        "This package provides a header-only unit testing library for C/C++.")
       (license license:unlicense))))
 
+(define-public nsync
+  (package
+    (name "nsync")
+    (version "1.26.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/google/nsync")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0qg58kkcbm4zqkql8j5yvrb7fpx09qsf7j93dwqb9s1y69l70kx4"))))
+    (build-system cmake-build-system)
+    (home-page "https://github.com/google/nsync")
+    (synopsis "C library for synchronization primitives")
+    (description
+     "nsync is a C library that exports various synchronization primitives:
+@enumerate
+@item locks
+@item condition variables
+@item run-once initialization
+@item waitable counter (useful for barriers)
+@item waitable bit (useful for cancellation, or other conditions)
+@end enumerate
+")
+    (license license:asl2.0)))
+
 (define-public ispc
   (package
     (name "ispc")