diff mbox series

[bug#70585] gnu: Add emacs-ellama.

Message ID ff0a121fc932046bb4acaa19fc28ea9da1821cd6.1714115406.git.roman@burningswell.com
State New
Headers show
Series [bug#70585] gnu: Add emacs-ellama. | expand

Commit Message

Roman Scherer April 26, 2024, 7:10 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ellama): New variable.

Change-Id: I47bf40971adca845aa132d08f59cd083154bec0e
---
 gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

This package depends on the emacs-llm package, which I submitted previously at bug#70584.


base-commit: bf984c5c80f460f36298f46b0389d4341086b47c
--
2.41.0
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8c712612b6..4945cee411 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4957,6 +4957,31 @@  (define-public emacs-elf-mode
 that the binary uses instead of the actual binary contents.")
     (license license:gpl3+)))

+(define-public emacs-ellama
+  (package
+    (name "emacs-ellama")
+    (version "0.9.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/s-kostyaev/ellama")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256 (base32
+                       "1nwwqvl91c65r45yxa2dcl4a41r3ahw6294h79riya48nrp8kn54"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-dash emacs-llm emacs-spinner))
+    (home-page "https://github.com/s-kostyaev/ellama")
+    (synopsis "Tool for interacting with LLMs")
+    (description
+     "Ellama is a tool for interacting with large language models from Emacs.
+It allows you to ask questions and receive responses from the LLMs.  Ellama
+can perform various tasks such as translation, code review, summarization,
+enhancing grammar/spelling or wording and more through the Emacs interface.
+Ellama natively supports streaming output, making it effortless to use with
+your preferred text editor.")
+    (license license:gpl3+)))
+
 (define-public emacs-org-fc
   (package
     (name "emacs-org-fc")