[bug#75317,2/6] gnu: gnucash: Do not install gnc-fq-update.

Message ID fed9e669d1b9bdce7bb8d55307de4c9bb6893029.1735912713.git.~@wolfsden.cz
State New
Headers
Series gnu: gnucash: Fix getting quotes |

Commit Message

Tomas Volf Jan. 3, 2025, 2:24 p.m. UTC
  This binary is used only for updating Finance::Quote from CPAN.  That does not
make sense on Guix, so do not install it.

* gnu/packages/gnucash.scm (gnucash)[arguments]<#:phases>: Add
delete-gnc-fq-update.

Change-Id: I93cf6d67166cce5970d48eea42de0ee5a5a9a8f8
---
 gnu/packages/gnucash.scm | 10 +++++++---
 1 file changed, 7 insertions(+), 3 deletions(-)
  

Patch

diff --git a/gnu/packages/gnucash.scm b/gnu/packages/gnucash.scm
index 6df2b76505..7ac7cb0d8f 100644
--- a/gnu/packages/gnucash.scm
+++ b/gnu/packages/gnucash.scm
@@ -160,12 +160,16 @@  (define-public gnucash
                                     (map (lambda (l)
                                            (assoc l (package-inputs this-package)))
                                          '("perl-finance-quote")))))))))
-               '("gnucash"
-                 "gnc-fq-update"))))
+               '("gnucash"))))
           (add-after 'install 'glib-or-gtk-compile-schemas
             (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
           (add-after 'install 'glib-or-gtk-wrap
-            (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
+            (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
+          (add-before 'glib-or-gtk-wrap 'delete-gnc-fq-update
+            (lambda _
+              ;; We are not updating Finance::Quote from CPAN.  There is no
+              ;; reason to install this binary.
+              (delete-file (string-append #$output "/bin/gnc-fq-update")))))))
     (native-inputs
      (list gmp
            `(,glib "bin")               ;glib-compile-schemas, etc.