diff mbox series

[bug#70567,v2,1/7] gnu: ocaml-lablgtk3-sourceview3: Fix inputs.

Message ID fed82eb94f9d8f797e8ff23f3f4d45657295c1de.1714058471.git.jean@foundation.xyz
State New
Headers show
Series [bug#70567,v2,1/7] gnu: ocaml-lablgtk3-sourceview3: Fix inputs. | expand

Commit Message

Jean-Pierre De Jesus Diaz April 25, 2024, 3:21 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-lablgtk3-sourceview3): Move gtksourceview-3 from
native-inputs to propagated-inputs.  Remove native-inputs and use
inherited inputs instead.

Change-Id: I2b242343bdace17ee3e992ce71f4e49b3c375e15
---
 gnu/packages/ocaml.scm | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)


base-commit: e5c130c0f90a7dacc8d223eee494a1b1105dd94a
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 7fad276b4e..920ccdcf36 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -28,7 +28,7 @@ 
 ;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
 ;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
 ;;; Copyright © 2023 Csepp <raingloom@riseup.net>
-;;; Copyright © 2023 Foundation Devices, Inc. <hello@foundationdevices.com>
+;;; Copyright © 2023,2024 Foundation Devices, Inc. <hello@foundation.xyz>
 ;;; Copyright © 2023 Arnaud DABY-SEESARAM <ds-ac@nanein.fr>
 ;;; Copyright © 2024 Sören Tempel <soeren@soeren-tempel.net>
 ;;;
@@ -8570,8 +8570,7 @@  (define-public ocaml-lablgtk3-sourceview3
   (package
     (inherit lablgtk3)
     (name "ocaml-lablgtk3-sourceview3")
-    (propagated-inputs (list lablgtk3))
-    (native-inputs (list gtksourceview-3 pkg-config))
+    (propagated-inputs (list gtksourceview-3 lablgtk3))
     (arguments
      `(#:package "lablgtk3-sourceview3"))
     (synopsis "OCaml interface to GTK+ gtksourceview library")