diff mbox series

[bug#68605,23/38] gnu: go-github-com-cloudflare-circl: Move to (gnu packages golang-crypto).

Message ID febfd4cf7009efb9779b96805ce68e769179fcb6.1705743628.git.sharlatanus@gmail.com
State New
Headers show
Series Split (gnu packages golang) part III | expand

Commit Message

Sharlatan Hellseher Jan. 20, 2024, 9:58 a.m. UTC
* gnu/packages/golang.scm (go-github-com-cloudflare-circl): Move from
here ...
* gnu/packages/golang-crypto.scm: ... to here.

Change-Id: I6d01b67c795d32387e0b77f1ea53d3a4a8f9939b
---
 gnu/packages/golang-crypto.scm | 29 +++++++++++++++++++++++++++++
 gnu/packages/golang.scm        | 29 -----------------------------
 2 files changed, 29 insertions(+), 29 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index bfeea103ca..23c47712a5 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -163,6 +163,35 @@  (define-public go-github-com-btcsuite-btcd-btcec
 needing to use secp256k1 elliptic curve cryptography.")
       (license license:isc))))
 
+(define-public go-github-com-cloudflare-circl
+  (package
+    (name "go-github-com-cloudflare-circl")
+    (version "1.3.6")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cloudflare/circl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "05hk5svprcjrj6k4mg4kd732pnb658llqv04z6xrcl5v77jda2kd"))))
+    (build-system go-build-system)
+    (arguments
+     '(#:import-path "github.com/cloudflare/circl"))
+    (propagated-inputs
+     (list go-github-com-bwesterb-go-ristretto
+           go-golang-org-x-crypto
+           go-golang-org-x-sys))
+    (home-page "https://blog.cloudflare.com/introducing-circl")
+    (synopsis "Cloudflare Interoperable Reusable Cryptographic Library")
+    (description "CIRCL (Cloudflare Interoperable, Reusable Cryptographic
+Library) is a collection of cryptographic primitives written in Go.  The goal
+of this library is to be used as a tool for experimental deployment of
+cryptographic algorithms targeting Post-Quantum (PQ) and Elliptic Curve
+Cryptography (ECC).")
+    (license license:bsd-3)))
+
 (define-public go-github-com-emersion-go-pgpmail
   (package
     (name "go-github-com-emersion-go-pgpmail")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index f6bec6c1c8..6eb14a8099 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5630,35 +5630,6 @@  (define-public go-github-com-minio-sha256-simd
 Architecture Processors\" by J. Guilford et al.")
     (license license:asl2.0)))
 
-(define-public go-github-com-cloudflare-circl
-  (package
-    (name "go-github-com-cloudflare-circl")
-    (version "1.3.6")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/cloudflare/circl")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "05hk5svprcjrj6k4mg4kd732pnb658llqv04z6xrcl5v77jda2kd"))))
-    (build-system go-build-system)
-    (arguments
-     '(#:import-path "github.com/cloudflare/circl"))
-    (propagated-inputs
-     (list go-github-com-bwesterb-go-ristretto
-           go-golang-org-x-crypto
-           go-golang-org-x-sys))
-    (home-page "https://blog.cloudflare.com/introducing-circl")
-    (synopsis "Cloudflare Interoperable Reusable Cryptographic Library")
-    (description "CIRCL (Cloudflare Interoperable, Reusable Cryptographic
-Library) is a collection of cryptographic primitives written in Go.  The goal
-of this library is to be used as a tool for experimental deployment of
-cryptographic algorithms targeting Post-Quantum (PQ) and Elliptic Curve
-Cryptography (ECC).")
-    (license license:bsd-3)))
-
 (define-public go-github-com-mr-tron-base58
   (let ((commit "d724c80ecac7b49e4e562d58b2b4f4ee4ed8c312")
         (revision "0"))