diff mbox series

[bug#69238,v2,08/10] gnu: go-github-com-songmu-gitconfig: Fix build.

Message ID fe8583254b8abeb81a8767c6cd5a153f5f84abd1.1708289807.git.sharlatanus@gmail.com
State New
Headers show
Series [bug#69238,v2,01/10] gnu: go-github-com-alecthomas-chroma: Move to golang-xyz. | expand

Commit Message

Sharlatan Hellseher Feb. 18, 2024, 8:59 p.m. UTC
As seen in <https://ci.guix.gnu.org/build/3490304/log/raw>.

* gnu/packages/golang-xyz.scm go-github-com-songmu-gitconfig: Update
style.
[arguments] <#:go>: Use go-1.21.

Change-Id: Iea7a32b51d4bd74e99c52938307c11177ae79199
---
 gnu/packages/golang-xyz.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index a6031a8354..2408916c39 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1036,10 +1036,12 @@  (define-public go-github-com-songmu-gitconfig
         (base32 "1y01h496a7pfj1g2bclls5b0nl3vnj7nz610jj1dzq9kxrwxk7fk"))))
     (build-system go-build-system)
     (arguments
-     `(#:import-path "github.com/Songmu/gitconfig"
-       ;; Package's tests appear to be hardcoded to the author's gitconfig
-       ;; and require network access.
-       #:tests? #f))
+     (list
+      ;; Package's tests appear to be hardcoded to the author's gitconfig
+      ;; and require network access.
+      #:tests? #f
+      #:go go-1.21
+      #:import-path "github.com/Songmu/gitconfig"))
     (propagated-inputs
      (list go-github-com-goccy-yaml))
     (synopsis "Go library to get configuration values from gitconfig")