diff mbox series

[bug#69932] gnu: shellutils: Add process-compose 0.88.0.

Message ID fe63794336d29e14d8d9f57f9e0f760b@lyrion.ch
State New
Headers show
Series [bug#69932] gnu: shellutils: Add process-compose 0.88.0. | expand

Commit Message

Daniel Ziltener March 21, 2024, 6:16 p.m. UTC
Sorry for the commit above; this one here is the corrected, working one.

---
 gnu/packages/shellutils.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index e58e9e61fc..fc8c1bc0f1 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -539,6 +539,34 @@  (define-public direnv
 environment variables of the current shell.")
     (license license:expat)))
 
+(define-public process-compose
+  (package
+    (name "process-compose")
+    (version "0.88.0")
+    (source
+     (origin
+       (method url-fetch/tarbomb)
+       (uri (string-append
+             "https://github.com/F1bonacc1/process-compose/releases/download/v"
+             version "/process-compose_linux_amd64.tar.gz"))
+       (sha256
+        (base32
+         "1qhfrbd5ybb0sinl9pad64rscr08qvlfzrzmi4p4hk61xn6phlmz"))))
+    (build-system trivial-build-system)
+    (arguments
+     (list
+      #:modules '((guix build utils))
+      #:builder #~(let ((source (assoc-ref %build-inputs "source"))
+                        (output (assoc-ref %outputs "out")))
+                    (use-modules (guix build utils))
+                    (install-file
+                     (string-append source "/process-compose") output))))
+    (home-page "https://f1bonacc1.github.io/process-compose")
+    (synopsis "Scheduler and orchestrator for processes")
+    (description "Process Compose is a simple and flexible scheduler and orchestrator
+to manage non-containerized applications.")
+    (license license:expat)))
+
 (define-public fzy
   (package
     (name "fzy")