@@ -3171,7 +3171,7 @@ (define-public youtube-dl
(define-public yt-dlp
(package
(name "yt-dlp")
- (version "2024.08.06")
+ (version "2024.10.22")
(source
(origin
(method git-fetch)
@@ -3179,8 +3179,11 @@ (define-public yt-dlp
(url "https://github.com/yt-dlp/yt-dlp/")
(commit version)))
(file-name (git-file-name name version))
+ (modules '((guix build utils)))
+ (snippet '(substitute* "pyproject.toml"
+ (("^.*Programming Language :: Python :: 3\\.13.*$") "")))
(sha256
- (base32 "0k44p1a9nckj7m6gxz7zggci0iihflivxvkh9l8wwbnsfvqhyfrn"))))
+ (base32 "1gw19f4h71vlchljg08g5l8sd60gmflbdpxz2vsinxzkmqvrqnra"))))
(build-system pyproject-build-system)
(arguments
`(#:tests? ,(not (%current-target-system))
From: Jakob Kirsch <jakob.kirsch@web.de> * gnu/packages/video.scm (yt-dlp): Update to 2024.10.22. Change-Id: Ifd83fd76ffdb2d2ddab0c9577278a308a3f03cb5 --- gnu/packages/video.scm | 7 +++++-- 1 file changed, 5 insertions(+), 2 deletions(-)