diff mbox series

[bug#69890,21/43] gnu: Add rust-named-pipe-0.4.

Message ID fdef8873e9979a9ddafa87bcff809a0de8b63432.1710817681.git.normally_js@posteo.net
State New
Headers show
Series gnu: Add procs. | expand

Commit Message

normally_js March 19, 2024, 3:50 a.m. UTC
* gnu/packages/crates-windows.scm (rust-named-pipe-0.4): New variable.

Change-Id: Ibf1baf32e0245e55c3213ff64bd8e0af67e7d8ff
---
 gnu/packages/crates-windows.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 14129b1ec4..eeb78f3d9a 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2023 Jaeme Sifat <jaeme@runbox.com>
 ;;; Copyright © 2023 Daniel Ziltener <dziltener@lyrion.ch>
 ;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
+;;; Copyright © 2024 normally_js <normally_js@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -495,6 +496,29 @@  (define-public rust-miow-0.2
        #:cargo-development-inputs
        (("rust-rand" ,rust-rand-0.3))))))
 
+(define-public rust-named-pipe-0.4
+  (package
+    (name "rust-named-pipe")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "named_pipe" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0azby10wzmsrf66m1bysbil0sjfybnvhsa8py093xz4irqy4975d"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-winapi" ,rust-winapi-0.3))))
+    (home-page "https://github.com/blackbeam/named_pipe")
+    (synopsis
+     "Wrapper for overlapped (asyncronous) IO of Windows's named pipes")
+    (description
+     "This package provides a wrapper for overlapped (asyncronous) IO of
+Windows's named pipes.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-output-vt100-0.1
   (package
     (name "rust-output-vt100")
@@ -2520,4 +2544,3 @@  (define-public rust-windows-x86-64-msvc-0.28
               (sha256
                (base32
                 "17z8q25pd3dp6b84qm9nlayd3ym78sbryxlqmgcxvz9vpmy8qarz"))))))
-