diff mbox series

[bug#67881] gnu: i2pd: Update to 2.50.0.

Message ID fde760c7e9e5d56f61e1b72c42cc767ebe1800e7.1702922755.git.mirai@makinata.eu
State New
Headers show
Series [bug#67881] gnu: i2pd: Update to 2.50.0. | expand

Commit Message

Bruno Victal Dec. 18, 2023, 6:09 p.m. UTC
Note: WITH_PCH flag was dropped with [1].

[1]: i2pd commit: a272a2cb7eedd2dc29c7a16d2b8c090658caf19d
     <https://github.com/PurpleI2P/i2pd/commit/a272a2cb7eedd2dc29c7a16d2b8c090658caf19d>

* gnu/packages/i2p.scm (i2pd): Update to 2.50.0.
[native-inputs]: Add pkg-config, check.
[arguments]: Use G-Expressions.
<#:configure-flags>: Drop obsolete and defaulted flags. Enable testing with
cmake.
<#:phases>: Drop obsolete 'check replacement.

Copyright-paperwork-exempt: Yes
---

Tested with:
1. In a terminal: ./pre-inst-env guix shell -C -N --no-cwd i2pd -- i2pd
2. Navigate to webconsole at <http://localhost:7070>.

 gnu/packages/i2p.scm | 44 ++++++++++++--------------------------------
 1 file changed, 12 insertions(+), 32 deletions(-)


base-commit: 29c94dd522833b2603a651c14a5b06120bcf1829

Comments

Guillaume Le Vaillant Dec. 20, 2023, 10:12 a.m. UTC | #1
Patch applied as 9dbb618a80a106a19a546f0f7b0769c89f103d4c.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/i2p.scm b/gnu/packages/i2p.scm
index 2e8c1d085d..b4f0c8d639 100644
--- a/gnu/packages/i2p.scm
+++ b/gnu/packages/i2p.scm
@@ -21,9 +21,12 @@ 
 
 (define-module (gnu packages i2p)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages upnp)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix git-download)
   #:use-module (guix build-system cmake)
@@ -32,7 +35,7 @@  (define-module (gnu packages i2p)
 (define-public i2pd
   (package
     (name "i2pd")
-    (version "2.44.0")
+    (version "2.50.0")
     (source
      (origin
        (method git-fetch)
@@ -41,41 +44,18 @@  (define-public i2pd
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0fwaalfxqdahgvx5rfkvdmf6gl10w328a18ddhyn5kvpmp9x7fgl"))))
+        (base32 "1vr251mgffawi3rj51dzlnv3fs1ssz6gl17qbsyhfr5fcd7s0hc5"))))
     (build-system cmake-build-system)
+    (native-inputs (list check pkg-config))
     (inputs
      (list boost miniupnpc openssl zlib))
     (arguments
-     '(#:configure-flags
-       (let ((source (assoc-ref %build-inputs "source")))
-         (list (string-append "-S" source "/build")
-               "-DWITH_PCH=OFF"
-               "-DWITH_STATIC=OFF"
-               "-DWITH_UPNP=ON"
-               "-DWITH_LIBRARY=ON"
-               "-DBUILD_SHARED_LIBS=ON"
-               "-DWITH_BINARY=ON"))
-       #:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key
-                     tests?
-                     (make-flags '())
-                     (parallel-tests? #t)
-                     #:allow-other-keys)
-             (let ((source (assoc-ref %build-inputs "source")))
-               (when tests?
-                 (copy-recursively (string-append source "/tests")
-                                   "./tests")
-                 (with-directory-excursion "tests"
-                   (substitute* "Makefile"
-                     (("../libi2pd") (string-append source "/libi2pd")))
-                   (apply invoke "make" "all"
-                          `(,@(if parallel-tests?
-                                `("-j" ,(number->string
-                                          (parallel-job-count)))
-                                '())
-                             ,@make-flags))))))))))
+     (list
+      #:configure-flags
+      #~(list (string-append "-S" #$source "/build")
+              "-DWITH_UPNP=ON"
+              "-DBUILD_SHARED_LIBS=ON"
+              "-DBUILD_TESTING=ON")))
     (home-page "https://i2pd.website/")
     (synopsis "Router for an end-to-end encrypted and anonymous internet")
     (description "i2pd is a client for the anonymous I2P network, upon which