diff mbox series

[bug#73066] gnu: kwin: Disable failing test on aarch64.

Message ID fddf68ec59c346716f7817ea97aafe65379e729a.1725617826.git.roman@burningswell.com
State New
Headers show
Series [bug#73066] gnu: kwin: Disable failing test on aarch64. | expand

Commit Message

Roman Scherer Sept. 6, 2024, 10:23 a.m. UTC
* gnu/packages/kde-plasma.scm (kwin): Disable failing test on aarch64.

Change-Id: Iecd9edbacca5805a54bcaf84bcec205367b96a05
---
 gnu/packages/kde-plasma.scm | 4 ++++
 1 file changed, 4 insertions(+)


base-commit: 7d2ced8d6d9c38327592d312376d59a8c37fc160

Comments

Z572 Sept. 6, 2024, 2:50 p.m. UTC | #1
Roman Scherer <roman@burningswell.com> writes:

> * gnu/packages/kde-plasma.scm (kwin): Disable failing test on aarch64.
>
> Change-Id: Iecd9edbacca5805a54bcaf84bcec205367b96a05
> ---
>  gnu/packages/kde-plasma.scm | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
> index 5e9b9688d1..7294a7555c 100644
> --- a/gnu/packages/kde-plasma.scm
> +++ b/gnu/packages/kde-plasma.scm
> @@ -29,6 +29,7 @@ (define-module (gnu packages kde-plasma)
>    #:use-module (guix git-download)
>    #:use-module ((guix licenses) #:prefix license:)
>    #:use-module (guix gexp)
> +  #:use-module (guix utils)
>    #:use-module (guix build-system cmake)
>    #:use-module (guix build-system trivial)
>    #:use-module (guix build-system qt)
> @@ -1429,6 +1430,9 @@ (define-public kwin
>                          "-E"
>                          (string-join
>                           (list
> +                          ;; Fails on an Apple M1 (aarch64) with the following error:
> +                          ;; TestColorspaces::roundtripConversion fails
> +                          #$(if (target-aarch64?) "kwin-testColorspaces" "")

adjust it to use  #$@(if (target-aarch64?)
                       #~("kwin-testColorspaces")
                       #~())
                    
only change it on aarch64.

>                            "kwin-testDrm" ;; require Drm
>                            "kwin-testInputMethod"
>                            "kwin-testPlasmaWindow" ;; require plasma-workspace qml module.
>
> base-commit: 7d2ced8d6d9c38327592d312376d59a8c37fc160
diff mbox series

Patch

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 5e9b9688d1..7294a7555c 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -29,6 +29,7 @@  (define-module (gnu packages kde-plasma)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix gexp)
+  #:use-module (guix utils)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system qt)
@@ -1429,6 +1430,9 @@  (define-public kwin
                         "-E"
                         (string-join
                          (list
+                          ;; Fails on an Apple M1 (aarch64) with the following error:
+                          ;; TestColorspaces::roundtripConversion fails
+                          #$(if (target-aarch64?) "kwin-testColorspaces" "")
                           "kwin-testDrm" ;; require Drm
                           "kwin-testInputMethod"
                           "kwin-testPlasmaWindow" ;; require plasma-workspace qml module.