diff mbox series

[bug#44640,3/3] gnu: Add python-git-hammer.

Message ID fddc55034c17332c2445e525f013f503812fb00c.camel@student.tugraz.at
State Accepted
Headers show
Series None | expand

Commit Message

Leo Prikler Nov. 17, 2020, 12:36 p.m. UTC
Attached are the revised patches 0002 and 0003.

Comments

Efraim Flashner Nov. 18, 2020, 8:40 a.m. UTC | #1
Looks good! Patches pushed.
diff mbox series

Patch

From c4f64923fafab6585ab7d6858d9e44dc59fb31e7 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Tue, 17 Nov 2020 13:22:22 +0100
Subject: [PATCH 3/3] gnu: Add python-git-hammer.

* gnu/packages/python-xyz.scm (python-git-hammer): New variable.
---
 gnu/packages/python-xyz.scm | 40 +++++++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 02ec4aec64..11e0570253 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18298,6 +18298,46 @@  supports the globstar @code{**} operator to match an arbitrary number of
 path components.")
     (license license:asl2.0)))
 
+(define-public python-git-hammer
+  (package
+    (name "python-git-hammer")
+    (version "0.3.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/asharov/git-hammer")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0f9xlk86ijzpdj25hr1q4wcy8k72v3w470ngwm9mpdkfj8ng84wr"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-setup.py
+           (lambda _
+             (substitute* "setup.py"
+               (("setup\\(")
+                "setup(\n    test_suite=\"test\",")))))))
+    (propagated-inputs
+     `(("python-beautifultable" ,python-beautifultable)
+       ("python-dateutil" ,python-dateutil)
+       ("python-gitpython" ,python-gitpython)
+       ("python-globber" ,python-globber)
+       ("python-matplotlib" ,python-matplotlib)
+       ("python-sqlalchemy" ,python-sqlalchemy)
+       ("python-sqlalchemy-utils"
+        ,python-sqlalchemy-utils)))
+    (home-page "https://github.com/asharov/git-hammer")
+    (synopsis "Provide statistics for git repositories")
+    (description
+     "Git Hammer is a statistics tool for projects in git repositories.
+Its major feature is tracking the number of lines authored by each person for every
+commit, but it also includes some other useful statistics.")
+    (license license:asl2.0)))
+
 (define-public python-fusepy
   (package
     (name "python-fusepy")
-- 
2.29.2