diff mbox series

[bug#44215,2/4] gnu: kpackage: Fix build errors in dependent packages.

Message ID fd79da3b13cab20660f8a2bdeb7265d6d31ec139.1603659776.git.h.goebel@crazy-compilers.com
State Accepted
Headers show
Series Some smaller KDE changes. | expand

Checks

Context Check Description
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel Oct. 25, 2020, 9:09 p.m. UTC
Fix build errors in dependent packages if PREFIX is different from ECM's
PREFIX - which is the case in Guix.  See <https://bugs.kde.org/424483> for
details.

* gnu/packages/patches/plasma-framework-fix-KF5PackageMacros.cmake.patch: New
  file.
* packages/kde-frameworks.scm (package)[source]: Use this patch.
---
 gnu/packages/kde-frameworks.scm               |  3 ++-
 .../kpackage-fix-KF5PackageMacros.cmake.patch | 25 +++++++++++++++++++
 2 files changed, 27 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch

Comments

Efraim Flashner Oct. 27, 2020, 8:54 a.m. UTC | #1
Same here about registering the patch
diff mbox series

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index cbcb8ff076..febdb1f4f0 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1963,7 +1963,8 @@  covers feedback and persistent events.")
                 "03rp7p7i8ihz5wg58gjs638jk7xbszknfiy2j3r979snc57g95mv"))
               ;; Default to: external paths/symlinks can be followed by a
               ;; package
-              (patches (search-patches "kpackage-allow-external-paths.patch"))))
+              (patches (search-patches "kpackage-allow-external-paths.patch"
+                                       "kpackage-fix-KF5PackageMacros.cmake.patch"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)))
diff --git a/gnu/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch b/gnu/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch
new file mode 100644
index 0000000000..d677f19a70
--- /dev/null
+++ b/gnu/packages/patches/kpackage-fix-KF5PackageMacros.cmake.patch
@@ -0,0 +1,25 @@ 
+From 668010ebc9fd84d9dc60f90b9a4ebf3c7054977f Mon Sep 17 00:00:00 2001
+From: Hartmut Goebel <h.goebel@crazy-compilers.com>
+Date: Sun, 25 Oct 2020 20:11:13 +0000
+Subject: [PATCH] Fix build errors if PREFIX is different from ECM's PREFIX.
+
+See <https://bugs.kde.org/424483> for details.
+---
+ KF5PackageMacros.cmake | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/KF5PackageMacros.cmake b/KF5PackageMacros.cmake
+index f4c1d1d..acd3798 100644
+--- a/KF5PackageMacros.cmake
++++ b/KF5PackageMacros.cmake
+@@ -1,6 +1,5 @@
+ 
+-find_package(ECM 1.6.0 CONFIG REQUIRED)
+-include(${ECM_KDE_MODULE_DIR}/KDEInstallDirs.cmake)
++include(KDEInstallDirs)
+ 
+ set(KPACKAGE_RELATIVE_DATA_INSTALL_DIR "kpackage")
+ 
+-- 
+GitLab
+