diff mbox series

[bug#65662,v1] gnu: Add antifennel.

Message ID fd5766c1ccce4ce84f03cf9a9d3f3a4100789468.1698850457.git.rteissier.code@chillpc.fr
State New
Headers show
Series [bug#65662,v1] gnu: Add antifennel. | expand

Commit Message

RĂ©mi Teissier Nov. 1, 2023, 2:54 p.m. UTC
Change-Id: Ic1f3fbc4d73ebc30291f4b60e7e8d16942c6627d
---
 gnu/packages/lua.scm | 33 +++++++++++++++++++++++++++++++++
 1 file changed, 33 insertions(+)


base-commit: 26565f1bc8548011bc0e1b821a9a957db1bc2d8f
diff mbox series

Patch

diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 65cab6511c..1cde6bd66c 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1269,6 +1269,39 @@  (define-public fennel
 system.")
     (license license:expat)))
 
+(define-public antifennel
+  (package
+    (version "0.2.0")
+    (name "antifennel")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~technomancy/antifennel")
+             (commit version)))
+       (sha256
+        (base32 "1hd9h17q31b3gg88c657zq4han4air2ag55rrakbmcpy6n8acsqc"))
+       (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (inputs (list luajit))
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'configure)
+                   ;; Tests pass after the fix introduced by the commit
+                   ;; ecd2169fcad1fa6616fdf6e6a8569f5b866601e5
+                   (delete 'check)
+                   (replace 'install
+                     (lambda _
+                       (install-file "antifennel"
+                                     (string-append #$output "/bin")))))))
+    (home-page "https://git.sr.ht/~technomancy/antifennel")
+    (synopsis "Turn Lua code into Fennel code")
+    (description
+     "This package provides a way to turn Lua code into Fennel code.
+This compiler does the opposite of what the Fennel compiler does.")
+    (license license:expat)))
+
 (define-public fnlfmt
   (package
     (name "fnlfmt")