diff mbox series

[bug#74075,v2,3/5] gnu: ogre: Update to 14.3.1.

Message ID fd507c5239e37a0b74d37ca1537e458d7982fb90.1730166007.git.maxim.cournoyer@gmail.com
State New
Headers show
Series [bug#74075,v2,1/5] gnu: imgui: Update to 1.91.4. | expand

Commit Message

Maxim Cournoyer Oct. 29, 2024, 1:40 a.m. UTC
* gnu/packages/graphics.scm (ogre): Update to 14.3.1.
[phases] <do-not-attempt-building-gtest, run-x-server>: New phases.
[native-inputs]: Update imgui source to latest.  Add xorg-server-for-tests.

Change-Id: Iabe6bb580106158976e7193bbb27d59df2466e29
---

(no changes since v1)

 gnu/packages/graphics.scm | 22 ++++++++++++++++------
 1 file changed, 16 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/graphics.scm b/gnu/packages/graphics.scm
index 0e13208d80..7659bec27d 100644
--- a/gnu/packages/graphics.scm
+++ b/gnu/packages/graphics.scm
@@ -21,7 +21,7 @@ 
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;; Copyright © 2020, 2021 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
-;;; Copyright © 2020, 2021, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020-2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2020 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2021 Antoine Côté <antoine.cote@posteo.net>
 ;;; Copyright © 2021 Andy Tai <atai@atai.org>
@@ -1176,7 +1176,7 @@  (define-public mangohud
 (define-public ogre
   (package
     (name "ogre")
-    (version "13.3.1")
+    (version "14.3.1")
     (source
      (origin
        (method git-fetch)
@@ -1185,12 +1185,17 @@  (define-public ogre
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "157vpfzivg2wf349glyd0cpbyaw1j3fm4nggban70pghql3x48kb"))))
+        (base32 "0l5rlxk2jiz8sb5w4bd8xvyzrmwnas27sxzkar7xc5azs1x2vgxf"))))
     (build-system cmake-build-system)
     (arguments
      (list
       #:phases
       #~(modify-phases %standard-phases
+          (add-after 'unpack 'do-not-attempt-building-gtest
+            (lambda _
+              (substitute* "Tests/CMakeLists.txt"
+                (("NOT EXISTS \\$\\{PROJECT_BINARY_DIR}/googletest-1.11.0")
+                 "FALSE"))))
           (add-before 'configure 'unpack-imgui
             (lambda _
               (copy-recursively #$(this-package-native-input "imgui-source")
@@ -1201,7 +1206,11 @@  (define-public ogre
             ;; it.
             (lambda _
               (substitute* "CMakeLists.txt"
-                (("set\\(CMAKE_INSTALL_RPATH .*") "")))))
+                (("set\\(CMAKE_INSTALL_RPATH .*") ""))))
+          (add-before 'check 'run-x-server
+            (lambda _
+              (system "Xvfb &")
+              (setenv "DISPLAY" ":0"))))
       #:configure-flags
       #~(let ((runpath (string-join (list (string-append #$output "/lib")
                                           (string-append #$output "/lib/OGRE"))
@@ -1215,10 +1224,11 @@  (define-public ogre
                 "-DOGRE_INSTALL_SAMPLES_SOURCE=TRUE"))))
     (native-inputs
      `(("doxygen" ,doxygen)
-       ("imgui-source" ,(package-source imgui-1.86))
+       ("imgui-source" ,(package-source imgui))
        ("googletest" ,googletest)
        ("pkg-config" ,pkg-config)
-       ("python" ,python)))
+       ("python" ,python)
+       ("xorg-server-for-tests" ,xorg-server-for-tests)))
     (inputs
      (list freeimage
            freetype