diff mbox series

[bug#65898,core-updates] gnu: ocaml: Allow not to build the native compiler.

Message ID fd47373f57c0b871a0e20b93ff8409ad061cdc36.1694551057.git.vivien@planete-kraus.eu
State New
Headers show
Series [bug#65898,core-updates] gnu: ocaml: Allow not to build the native compiler. | expand

Commit Message

Vivien Kraus Sept. 12, 2023, 8:31 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-5.0) [entry point]: Build "defaultentry", not
"world.opt", so that the build system decides whether to build the native
compiler or just the bytecode compiler. The native compiler is not available
for 32-bit architectures.
---
 gnu/packages/ocaml.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: e79afd5d2574eb35f54c070a3f6048806721ef04

Comments

Vivien Kraus Sept. 12, 2023, 9:32 p.m. UTC | #1
Hi,

The native compiler for ocaml is not always available, especially for
i686-linux. The first step is to get the "best" possible compiler
instead of requiring the native compiler. However, building for i686-
linux still fails. The test suite reports no failure nor error, but it
still fails. What does that mean?

```
Summary:
  2285 tests passed
  592 tests skipped
    0 tests failed
  569 tests not started (parent test skipped or failed)
    0 unexpected errors
  3446 tests considered
make[1]: Leaving directory '/tmp/guix-build-ocaml-5.0.0.drv-
0/source/testsuite'

Test suite failed, dumping logs.
```

Vivien
Andreas Enge Sept. 16, 2023, 7:48 a.m. UTC | #2
Hello Vivien,

it has been built by QA, so I have pushed the patch and close this issue.
Thanks!

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 8ff755aea9..ea9d3e3594 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -219,7 +219,7 @@  (define-public ocaml-5.0
     (arguments
      `(#:configure-flags '("--enable-ocamltest")
        #:test-target "tests"
-       #:make-flags '("world.opt")
+       #:make-flags '("defaultentry")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-/bin/sh-references