[bug#75420,python-team,02/11] gnu: python-yarl: Update to 1.12.1.

Message ID fd232d9c15b52b8861fcc66e4b019a08624bb1a2.1736256868.git.arjan@adriaan.se
State New
Headers
Series Fix python-matrix-nio and pantalaimon builds. |

Commit Message

Arjan Adriaanse Jan. 7, 2025, 2:09 p.m. UTC
  * gnu/packages/python-web.scm (python-yarl): Update to 1.12.1.

Change-Id: Ia35413c952042ce81eaac3ba10e90b4b333e8386
---
 gnu/packages/python-web.scm | 43 +++++++++++++++++++------------------
 1 file changed, 22 insertions(+), 21 deletions(-)
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index de6a2b91ae..56e2d2aa39 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -69,6 +69,7 @@ 
 ;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2024 Spencer King <spencer.king@geneoscopy.com>
 ;;; Copyright © 2024 Attila Lendvai <attila@lendvai.name>
+;;; Copyright © 2025 Arjan Adriaanse <arjan@adriaan.se>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6103,35 +6104,35 @@  (define-public python-pycares
 (define-public python-yarl
   (package
     (name "python-yarl")
-    (version "1.6.3")
+    (version "1.12.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "yarl" version))
        (sha256
-        (base32
-         "045z4ssg8g5h0qhz8hnx74hswgkndaldqq1xi5l1n5s0j996d44a"))
-       (modules '((guix build utils)))
-       (snippet
-         #~(begin
-             (delete-file "yarl/_quoting_c.c")))))
-    (build-system python-build-system)
+        (base32 "0a2qh676xlpzb40an2m5k2hnql6fjr8krvnwwipqvv4s35ah11jv"))))
+    (build-system pyproject-build-system)
     (arguments
-      (list #:tests? #f     ; test suite can't find yarl._quoting_c
-            #:phases
+      (list #:phases
             #~(modify-phases %standard-phases
-                (add-after 'unpack 'cythonize-code
+                (add-after 'unpack 'force-build-inplace
                   (lambda _
-                    (invoke "cython" "yarl/_quoting_c.pyx")))
-                (replace 'check
-                  (lambda* (#:key tests? inputs outputs #:allow-other-keys)
-                    (when tests?
-                      (substitute* "setup.cfg"
-                        (("--cov=yarl") ""))
-                      (add-installed-pythonpath inputs outputs)
-                      (invoke "python" "-m" "pytest")))))))
-    (native-inputs
-     (list python-cython python-pytest python-pytest-runner))
+                    ;; This makes sure the resulting wheel ends up in a
+                    ;; location where it can be found for installing.
+                    (substitute* "packaging/pep517_backend/_backend.py"
+                      (("build_inplace=False")
+                       "build_inplace=True"))
+                    #t)))))
+    (native-inputs
+     (list python-covdefaults
+           python-cython
+           python-expandvars
+           python-pytest
+           python-pytest-cov
+           python-pytest-xdist
+           python-setuptools
+           python-tomli
+           python-wheel))
     (propagated-inputs
      (list python-idna python-multidict))
     (home-page "https://github.com/aio-libs/yarl/")