diff mbox series

[bug#64021,v2,6/6] gnu: gajim: Clean up formatting.

Message ID fcfc095318526625c5dce27cadc6b09204bab0d0.1688488273.git.poomklao@yahoo.com
State New
Headers show
Series [bug#64021,v2,1/6] gnu: python-nbxmpp: Update to 4.2.2. | expand

Commit Message

Parnikkapore July 4, 2023, 4:31 p.m. UTC
* gnu/packages/messaging.scm (gajim): Clean up formatting.
---
 gnu/packages/messaging.scm | 36 +++++++++++++++++++-----------------
 1 file changed, 19 insertions(+), 17 deletions(-)

Comments

Christopher Baines Sept. 27, 2023, 11:14 a.m. UTC | #1
Hi,

Thanks for sending a v2, unfortunately this got a bit lost.

I've tweaked the formatting of some commit messages, made arguments a
(list rather than a `( quasiquoted list in a few cases and I've pushed
these patches to master as 8bc78fc86b928f603a589e413e9f20815a194f17.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index bee9750055..2d377d0bcb 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1128,13 +1128,13 @@  (define-public gajim
     (source
      (origin
        (method url-fetch)
-       (uri
-        (string-append "https://gajim.org/downloads/"
-                       (version-major+minor version)
-                       "/gajim-" version ".tar.gz"))
+       (uri (string-append "https://gajim.org/downloads/"
+                           (version-major+minor version)
+                           "/gajim-" version ".tar.gz"))
        (sha256
-        (base32 "066kvkjw3qcdanr3nczy0wgcwihk9jc9zhzfr5bwlqvcyxcv7k5p"))
-       (patches (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
+         (base32 "066kvkjw3qcdanr3nczy0wgcwihk9jc9zhzfr5bwlqvcyxcv7k5p"))
+       (patches
+         (search-patches "gajim-honour-GAJIM_PLUGIN_PATH.patch"))))
     (build-system python-build-system)
     (arguments
      `(#:imported-modules
@@ -1142,8 +1142,7 @@  (define-public gajim
         (guix build glib-or-gtk-build-system))
        #:modules
        ((guix build python-build-system)
-        ((guix build glib-or-gtk-build-system)
-         #:prefix glib-or-gtk:)
+        ((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
         (guix build utils))
        #:phases
        ,#~(modify-phases %standard-phases
@@ -1152,12 +1151,14 @@  (define-public gajim
                       'generate-gdk-pixbuf-loaders-cache-file))
          (add-before 'build 'build-metadata
            (lambda _
-             (invoke "./pep517build/build_metadata.py" "-o" "dist/metadata")))
+             (invoke "./pep517build/build_metadata.py"
+                     "-o" "dist/metadata")))
          ;; TODO: Change to pyproject-build-system once it supports
          ;; in-tree build backends.
          (replace 'build
            (lambda _
-             (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
+             (invoke "python" "-m" "build" "--wheel" "--no-isolation"
+                     ".")))
          (replace 'install
            (lambda _
              (apply invoke "pip" "--no-cache-dir" "--no-input"
@@ -1174,11 +1175,14 @@  (define-public gajim
              (setenv "DISPLAY" ":1")
              ;; For missing '/etc/machine-id'.
              (setenv "DBUS_FATAL_WARNINGS" "0")
-             (invoke "dbus-launch" "python" "-m" "unittest" "discover" "-s" "test")))
+             (invoke "dbus-launch" "python" "-m" "unittest"
+                     "discover" "-s" "test")))
          (add-after 'install 'glib-or-gtk-compile-schemas
-           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-compile-schemas))
+           (assoc-ref glib-or-gtk:%standard-phases
+                      'glib-or-gtk-compile-schemas))
          (add-after 'install 'glib-or-gtk-wrap
-           (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap))
+           (assoc-ref glib-or-gtk:%standard-phases
+                      'glib-or-gtk-wrap))
          (add-after 'install 'wrap-env
            (lambda _
              (for-each
@@ -1196,10 +1200,8 @@  (define-public gajim
      (list
       (search-path-specification
        (variable "GAJIM_PLUGIN_PATH")
-       (separator #f)                   ;single entry
-       (files
-        (list
-         "share/gajim/plugins")))
+       (separator #f) ; single entry
+       (files (list "share/gajim/plugins")))
       ;; Gajim needs to use the propagated inputs of its plugins.
       (search-path-specification
        (variable "GUIX_PYTHONPATH")