diff mbox series

[bug#63991,v2,1/3] gnu: Add rang

Message ID fcb90cbfeb603bce8f86f7cbe90fc6d4e8b1b52b.1686980668.git.atai@atai.org
State New
Headers show
Series [bug#63991,v2,1/3] gnu: Add rang | expand

Commit Message

Andy Tai June 17, 2023, 5:45 a.m. UTC
* gnu/packages/cpp.scm (rang): New variable
---
 gnu/packages/cpp.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: 998d89ba20121e87664129890a805c91061baaa7
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 39a34c20dd..3d43a0c999 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2553,3 +2553,24 @@  (define-public ftxui
 @item No dependencies.
 @end itemize")
     (license license:expat)))
+
+(define-public rang
+  (package
+    (name "rang")
+    (version "3.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/agauniyal/rang")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0x2fp7zjjivgxblvx1j0qphn4ln6jq42x7xr757fywm3k03y7bil"))))
+    (build-system cmake-build-system)
+    (arguments (list #:tests? #f))  ; no tests
+    (home-page "https://agauniyal.github.io/rang/")
+    (synopsis "Header only terminal c++ library")
+    (description
+     "Rang is a Minimal, Header only Modern c++ library for terminal goodies.")
+    (license license:asl2.0)))