diff mbox series

[bug#40044] gnu: BlueZ: Update to 5.53 [security fixes].

Message ID fc22dc49f42daa015606d367ca7e1f6e3c538dae.1584041380.git.leo@famulari.name
State Accepted
Headers show
Series [bug#40044] gnu: BlueZ: Update to 5.53 [security fixes]. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Famulari March 12, 2020, 7:29 p.m. UTC
Apparently this fixes a privilege escalation bug:

https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00352.html

* gnu/packages/linux.scm (bluez-5.53): New variable.
(bluez)[replacement]: New field.
---
 gnu/packages/linux.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)

Comments

Leo Famulari March 13, 2020, 4:26 p.m. UTC | #1
On Thu, Mar 12, 2020 at 03:29:40PM -0400, Leo Famulari wrote:
> Apparently this fixes a privilege escalation bug:
> 
> https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00352.html
> 
> * gnu/packages/linux.scm (bluez-5.53): New variable.
> (bluez)[replacement]: New field.

Intel and I were mistaken — the bug fix is not included in the 5.53
release. So this patch should be disregarded.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 01986222e8..61b02591a4 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3995,6 +3995,7 @@  Bluetooth audio output devices like headphones or loudspeakers.")
   (package
     (name "bluez")
     (version "5.52")
+    (replacement bluez-5.53)
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -4059,6 +4060,19 @@  Bluetooth audio output devices like headphones or loudspeakers.")
 is flexible, efficient and uses a modular implementation.")
     (license license:gpl2+)))
 
+(define bluez-5.53
+  (package
+    (inherit bluez)
+    (version "5.53")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://kernel.org/linux/bluetooth/bluez-"
+                    version ".tar.xz"))
+              (sha256
+               (base32
+                "1g1qg6dz6hl3csrmz75ixr12lwv836hq3ckb259svvrg62l2vaiq"))))))
+
 (define-public fuse-exfat
   (package
     (name "fuse-exfat")