[bug#78045,2/2] gnu: Add emacs-xhair.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-xhair): New variable.
Change-Id: I6a046eaf50795b515f8800b4da0b73c8de40e33a
---
gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)
@@ -17188,6 +17188,32 @@ (define-public emacs-vline
enhances text editing by visually indicating the vertical line.")
(license license:gpl3+)))
+(define-public emacs-xhair
+ (package
+ (name "emacs-xhair")
+ (version "20210801.222")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Boruch-Baum/emacs-xhair.git")
+ (commit "c7bd7c501c3545aa99dadac386c882fe7c5edd9c")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "03m15lbspk73x59wvb77wgvnkrmrlq4w6kmnrr2i69jgafqh0421"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-vline))
+ (home-page "https://github.com/Boruch-Baum/emacs-xhair")
+ (synopsis "Highlight the current line and column")
+ (description
+ "This package simultaneously applies `vline-mode and `hl-line-mode', with
+tweaks,to present POINT in highlighted cross-hairs, reporting the value of
+POINT as a message in the echo area. This will remain in effect until toggled
+manually (function `xhair-mode by default), or until the next
+keypress (function `xhair by default), or for a set interval (function
+`xhair-flash by default).")
+ (license license:gpl3+)))
+
(define-public emacs-ryo-modal
;; Package has no release. Version is extracted from "Version:" keyword in
;; main file.