[bug#77159,6/7] gnu: zathura-ps: Update to 0.2.8.

Message ID fc072a57666ff701849cf26899c035bb7e75c787.1742591224.git.wongandj@icloud.com
State New
Headers
Series Update Zathura and plugins |

Commit Message

Andrew Wong March 21, 2025, 9:11 p.m. UTC
  * gnu/packages/pdf.scm (zathura-ps): Update to 0.2.8.
[arguments] <#:phases>: Remove unneeded 'patch-plugin-directory phase

Change-Id: Ib05756b8fb2729c5bf996301440a90832220dd29
---
 gnu/packages/pdf.scm | 31 ++++++++++---------------------
 1 file changed, 10 insertions(+), 21 deletions(-)
  

Patch

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index cfdf8d9289..4a32473f89 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -548,31 +548,20 @@  (define-public zathura-cb
 (define-public zathura-ps
   (package
     (name "zathura-ps")
-    (version "0.2.7")
-    (source (origin
-              (method url-fetch)
-              (uri
-               (string-append "https://pwmt.org/projects/zathura-ps/download/zathura-ps-"
-                              version ".tar.xz"))
-              (sha256
-               (base32
-                "0ilf63wxn1yzis9m3qs8mxbk316yxdzwxrrv86wpiygm9hhgk5sq"))))
+    (version "0.2.8")
+    (source
+     (origin (method url-fetch)
+             (uri (string-append "https://pwmt.org/projects/zathura-ps"
+                                 "/download/zathura-ps-" version ".tar.xz"))
+             (sha256
+              (base32 "0jifjfl3dzwyavwr0g795109d8iy6hc8811q01nqgybpf97mkjh7"))))
     (native-inputs (list pkg-config))
     (inputs (list libspectre zathura))
     (build-system meson-build-system)
     (arguments
-     `(#:tests? #f                      ; package does not contain tests
-       #:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'patch-plugin-directory
-           ;; Something of a regression in 0.2.7: the new Meson build system
-           ;; now hard-codes an incorrect plugin directory.  Fix it.
-           (lambda* (#:key outputs #:allow-other-keys)
-             (substitute* "meson.build"
-               (("(install_dir:).*" _ key)
-                (string-append key
-                               "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
-             #t)))))
+     (list #:tests? #f                  ; package does not contain tests
+           #:configure-flags
+           #~(list (string-append "-Dplugindir=" #$output "/lib/zathura"))))
     (home-page "https://pwmt.org/projects/zathura-ps/")
     (synopsis "PS support for zathura (libspectre backend)")
     (description "The zathura-ps plugin adds PS support to zathura