diff mbox series

[bug#69272,v2,4/4] gnu: Add prosody-vcard-muc.

Message ID fbf74cdc2091a7a97402f7aeeabf22e748928d2e.1708379059.git.carlo@zancanaro.id.au
State New
Headers show
Series None | expand

Commit Message

Carlo Zancanaro Feb. 19, 2024, 9:44 p.m. UTC
* gnu/packages/messaging.scm (prosody-vcard-muc): New variable.

Change-Id: I57eae8373369e7e954084803fd7b861ab85ce4ad
---
 gnu/packages/messaging.scm | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Liliana Marie Prikler March 2, 2024, 6:42 a.m. UTC | #1
Hi,

Am Dienstag, dem 20.02.2024 um 08:44 +1100 schrieb Carlo Zancanaro:
> * gnu/packages/messaging.scm (prosody-vcard-muc): New variable.
> 
> Change-Id: I57eae8373369e7e954084803fd7b861ab85ce4ad
> ---
>  gnu/packages/messaging.scm | 7 +++++++
>  1 file changed, 7 insertions(+)
> 
> diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
> index ef009577c4..421a7afd78 100644
> --- a/gnu/packages/messaging.scm
> +++ b/gnu/packages/messaging.scm
> @@ -1625,6 +1625,13 @@ (define-public prosody-smack
>  the client and server, it can allow clients to resume a disconnected
> session,
>  and prevent message loss.")))
>  
> +(define-public prosody-vcard-muc
> +  (package
> +    (inherit (prosody-module "mod_vcard_muc"))
> +    (synopsis "Support for MUC vCards and avatars")
> +    (description "This module adds the ability to set vCard for MUC
> rooms. One
> +of the most common use cases is to define avatars for MUC rooms.")))
> +
Trying to build this locally, I get a hash mismatch for the checkout.

  expected hash: 142wrcism70nf8ffahhd961cqg2pi1h7ic8adfs3zwh0j3pnf41f
  actual hash:   1nvka8s3zqs97jqsknhp2q956rrdga1qaxa1y3i0h8zx3g9vgdch

Do the hashes on prosody change that quickly?
Carlo Zancanaro March 2, 2024, 11:27 a.m. UTC | #2
Hi Liliana,

On Sat, Mar 02 2024, Liliana Marie Prikler wrote:
> Do the hashes on prosody change that quickly?

Nope! This is using a mercurial checkout, so the hashes shouldn't change
at all. I just made a mistake in my commits. Patch 3/4 in v2 updates the
changeset and revision, but not the expected hash. I'm not sure how I
messed this up, given patch 3/4 in v1 updated the hash.

The actual hash that you got is the same as my v1 patch:
1nvka8s3zqs97jqsknhp2q956rrdga1qaxa1y3i0h8zx3g9vgdch

I'll send through a v3 today.

Carlo

P.S. Apologies that you'll get this message twice. I forgot to Cc the
bug tracer on the first attempt.
Liliana Marie Prikler March 2, 2024, 1 p.m. UTC | #3
Am Samstag, dem 02.03.2024 um 22:27 +1100 schrieb Carlo Zancanaro:
> P.S. Apologies that you'll get this message twice. I forgot to Cc the
> bug tracer on the first attempt.
Apologies from me for not checking earlier.

Pushed now, thanks!
Carlo Zancanaro March 3, 2024, 4:07 a.m. UTC | #4
On Sat, Mar 02 2024, Liliana Marie Prikler wrote:
> Pushed now, thanks!

Unfortunately I've discovered another silly mistake:
bca48fdef48150a3c4e96e3941feb1986ea3e631 refactored things, but
accidentally changed the "prosody-smacks" package's variable name to
"prosody-smack".

I can put together a patch to change this back, but I don't have time to
do so right now. If anyone else gets to it before me then please feel
free to fix it! 🙂

Carlo
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index ef009577c4..421a7afd78 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1625,6 +1625,13 @@  (define-public prosody-smack
 the client and server, it can allow clients to resume a disconnected session,
 and prevent message loss.")))
 
+(define-public prosody-vcard-muc
+  (package
+    (inherit (prosody-module "mod_vcard_muc"))
+    (synopsis "Support for MUC vCards and avatars")
+    (description "This module adds the ability to set vCard for MUC rooms. One
+of the most common use cases is to define avatars for MUC rooms.")))
+
 (define-public libtoxcore
   (let ((revision "2")
         (commit "bf69b54f64003d160d759068f4816b2d9b2e1e21"))