diff mbox series

[bug#67719,2/3] gnu: darktable: Build with GCC again.

Message ID fbea74fb69077edf23dd2de8c206e3e6e87f5cce.1702073949.git.monego@posteo.net
State New
Headers show
Series GMIC, Darktable updates | expand

Commit Message

Vinicius Monego Dec. 8, 2023, 10:22 p.m. UTC
* gnu/packages/photo.scm (darktable)[arguments][#:phases]: Delete the
'prepare-build-environment phase.
[native-inputs]: Remove clang. Add gcc-13.

Change-Id: Ia0dc1c6a717ccd00cd31d378aa51ce63fbf1806a
---
 gnu/packages/photo.scm | 18 ++++--------------
 1 file changed, 4 insertions(+), 14 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 86b7fbd15c..aa857a1d83 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -54,6 +54,7 @@  (define-module (gnu packages photo)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages file)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages gcc)
   #:use-module (gnu packages geo)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages ghostscript)
@@ -553,17 +554,6 @@  (define-public darktable
                  (string-append "\""
                                 (search-input-file inputs "/lib/libOpenCL.so")
                                 "\"")))))
-          (add-before 'configure 'prepare-build-environment
-            (lambda _
-              ;; Rawspeed fails to build with GCC due to OpenMP error:
-              ;; "undefined reference to `GOMP_loop_nonmonotonic_dynamic_next'"
-              (setenv "CC" "clang")
-              (setenv "CXX" "clang++")
-              ;; Darktable looks for opencl-c.h in the LLVM dir. Guix installs
-              ;; it to the Clang dir. We fix this by patching CMakeLists.txt.
-              (substitute* "CMakeLists.txt"
-                (("\\$\\{LLVM_INSTALL_PREFIX\\}")
-                 #$(this-package-native-input "clang")))))
           (add-before 'configure 'set-LDFLAGS
             (lambda _
               (setenv "LDFLAGS"
@@ -576,13 +566,13 @@  (define-public darktable
                   (,(string-append #$(this-package-input "gtk+")
                                    "/share/glib-2.0/schemas")))))))))
     (native-inputs
-     (list clang
-           cmocka
+     (list cmocka
            desktop-file-utils
+           gcc-13             ; gcc-11 too old for darktable, 12+ required
            `(,glib "bin")
            gobject-introspection
            intltool
-           llvm                         ;should match the Clang version
+           llvm
            opencl-headers
            perl
            pkg-config