diff mbox series

[bug#58358,1/3] gnu: bashtop: Deprecate for bpytop.

Message ID fb90edb38f7b1d6095717af49a3bf8da33ff2b1a.1665154432.git.code@greghogan.com
State Accepted
Headers show
Series Update btop. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Greg Hogan Oct. 7, 2022, 2:59 p.m. UTC
* gnu/packages/admin.scm (bashtop): Deprecate for bpytop.
---
 gnu/packages/admin.scm | 49 +++++++++++++++++++++---------------------
 1 file changed, 25 insertions(+), 24 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 13d582403b..0f3fcaa5e3 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -751,30 +751,6 @@  (define-public htop
 application (for console or X terminals) and requires ncurses.")
     (license license:gpl2)))
 
-(define-public bashtop
-  (package
-    (name "bashtop")
-    (version "0.9.25")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "https://github.com/aristocratos/bashtop")
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "07nlr6vmyb7yihaxj1fp424lmhwkdjl6mls92v90f6gsvikpa13v"))))
-    (build-system gnu-build-system)
-    (arguments
-     '(#:make-flags (list (string-append "PREFIX=" %output))
-       #:tests? #f      ; bats test fails with loading load.bash
-       #:phases (modify-phases %standard-phases (delete 'configure))))
-    (home-page "https://github.com/aristocratos/bashtop")
-    (synopsis "Linux/OSX/FreeBSD resource monitor")
-    (description "Resource monitor that shows usage and stats for processor,
-memory, disks, network and processes.")
-    (license license:asl2.0)))
-
 (define-public bpytop
   (package
     (name "bpytop")
@@ -810,6 +786,31 @@  (define-public bpytop
 @command{bashtop}.")
     (license license:asl2.0)))
 
+(define-public bashtop
+  (package
+    (name "bashtop")
+    (version "0.9.25")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/aristocratos/bashtop")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "07nlr6vmyb7yihaxj1fp424lmhwkdjl6mls92v90f6gsvikpa13v"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:make-flags (list (string-append "PREFIX=" %output))
+       #:tests? #f      ; bats test fails with loading load.bash
+       #:phases (modify-phases %standard-phases (delete 'configure))))
+    (home-page "https://github.com/aristocratos/bashtop")
+    (synopsis "Linux/OSX/FreeBSD resource monitor")
+    (description "Resource monitor that shows usage and stats for processor,
+memory, disks, network and processes.")
+    (license license:asl2.0)
+    (properties `((superseded . ,bpytop)))))
+
 (define-public pies
   (package
     (name "pies")