diff mbox series

[bug#74290,03/31] gnu: hurd: Update to v0.9.git20240714.

Message ID fae55dd7027b6cb60c0e1cd6a1129ea1e2a632b6.1731232753.git.janneke@gnu.org
State New
Headers show
Series Add support for x86_64-gnu, aka the 64bit Hurd. | expand

Commit Message

Janneke Nieuwenhuizen Nov. 10, 2024, 10:37 a.m. UTC
* gnu/packages/hurd.scm (hurd-headers): Update to v0.9.git20240714.
(hurd)[arguments]: Remove rumpdisk build hack from "prepare-addons" stage.
Instead, when cross-compiling, add stage "fixup-cross-configure" to enable
rumpdisk.
* gnu/system.scm (hurd-multiboot-modules): Remove
"--x-xattr-translator-records" option that has been removed and is now the
default.

Change-Id: I4609b5a959c1ece98e2fe1aedbb1d31d6edadcca
---
 gnu/packages/hurd.scm | 12 +++++++++---
 gnu/system.scm        |  1 -
 2 files changed, 9 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 28f39cc448..06fae1bd3b 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -132,7 +132,7 @@  (define-public mig
 
 (define-public hurd-headers
   (let ((revision "3")
-        (commit "v0.9.git20231217"))
+        (commit "v0.9.git20240714"))
     (package
       (name "hurd-headers")
       (version (string-drop commit 1))
@@ -143,7 +143,7 @@  (define-public hurd-headers
                       (commit commit)))
                 (sha256
                  (base32
-                  "1d138kzhil6s5gf9di8grpz1iziakyfv037wkc8s7qyd61imm31d"))
+                  "0wvzil3llmrjg7ymwqs86d11bm5fl771jwncv7kk679lsvqca0ll"))
                 (file-name (git-file-name name version))))
       (build-system gnu-build-system)
       (native-inputs
@@ -336,7 +336,7 @@  (define-public hurd
              ;; Makefile. libdde_linux26 is built later in its own phase.
              (substitute* "Makefile"
                (("libbpf ")
-                "libbpf libmachdevdde libddekit rumpdisk"))))
+                "libbpf libmachdevdde libddekit "))))
          (add-after 'unpack 'find-tirpc
            (lambda* (#:key inputs #:allow-other-keys)
              (for-each (lambda (var)
@@ -362,6 +362,12 @@  (define-public hurd
                (("#include <rpc/pmap_prot.h>" m)
                 (string-append "#include <rpc/types.h>\n#include <rpc/xdr.h>\n" m)))
              #t))
+         ,@(if (%current-target-system)
+               '((add-after 'configure 'fixup-cross-configure
+                   (lambda _
+                     (substitute* "config.make"
+                       (("HAVE_LIBRUMP = no") "HAVE_LIBRUMP = yes")))))
+               '())
          (add-before 'build 'pre-build
            (lambda _
              ;; Don't change the ownership of any file at this time.
diff --git a/gnu/system.scm b/gnu/system.scm
index 533a4154d6..6e1ebbcc9c 100644
--- a/gnu/system.scm
+++ b/gnu/system.scm
@@ -1534,7 +1534,6 @@  (define (hurd-multiboot-modules os)
                 "--multiboot-command-line='${kernel-command-line}'"
                 "--exec-server-task='${exec-task}'"
                 "--store-type=typed"
-                "--x-xattr-translator-records"
                 "'${root}'"
                 "'$(fs-task=task-create)'"))
          (target (%current-target-system))