diff mbox series

[bug#71751] gnu: python-trio: Disable failing test.

Message ID fa8914ba1e89d7031b31d6741fa2787e67bec8dd.1719249491.git.juli@incana.org
State New
Headers show
Series [bug#71751] gnu: python-trio: Disable failing test. | expand

Commit Message

Juliana Sims June 24, 2024, 5:18 p.m. UTC
Hello,

This test has begun failing, causing the build of python-trio to fail as well.

Oddly, there doesn't appear to be any change in the Trio code that should
trigger a new test failure, so this may not be the best solution. However, the
code for is_main_thread() relies on signals working properly, which, as the
adjacent comment points out, does not work at build time.

If anyone has a better idea of what's going on here and, therefore, how to fix
it, feel free to offer input or a better patch. In the meantime, this should get
python-trio and its dependants building again.

Thanks,
Juli

* gnu/packages/python-xyz.scm [arguments]: Disable failing test.

Change-Id: I8a066fd17654ce8b1dfb0411d8df621e0f45a63d
---
 gnu/packages/python-xyz.scm | 1 +
 1 file changed, 1 insertion(+)


base-commit: ac105faf4ceb67468c7011505a07a67b0c1b045f

Comments

Juliana Sims June 24, 2024, 5:29 p.m. UTC | #1
I happened to be reading the NEWS file for Guile 3.0.10 when my system 
reconfigure failed, leading me to notice and fix this failing build. 
After submitting this bug, I returned to reading that file and noticed 
a mention of signal handling in child processes[1]. Could this be 
related to the present issue of signals at build time?

-Juli

[1] http://git.savannah.gnu.org/cgit/guile.git/tree/NEWS#n206
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9ad89b8c32e..341b0c6feaf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28882,6 +28882,7 @@  (define-public python-trio
                          " and not test_for_leaking_fds"
                          ;; Signals don’t work in the build sandbox.
                          " and not test_open_signal_receiver"
+                         " and not test_is_main_thread"
                          ;; These try to raise KeyboardInterrupt which does not work
                          ;; in the build environment.
                          " and not test_ki_self"