diff mbox series

[bug#47387] gnu: Add emacs-nice-citation.

Message ID fa4b8fb8f1803c55b845e58eab0e70858958bd16.1616679513.git.public@yoctocell.xyz
State Accepted
Headers show
Series [bug#47387] gnu: Add emacs-nice-citation. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Xinglu Chen March 25, 2021, 1:39 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-nice-citation): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)


base-commit: ab170124a327b4b359fc440796b18fadb0516f3c

Comments

Nicolas Goaziou March 26, 2021, 2:08 p.m. UTC | #1
Hello,

Xinglu Chen <public@yoctocell.xyz> writes:

> * gnu/packages/emacs-xyz.scm (emacs-nice-citation): New variable.

Thank you. I applied your patch with the following changes.

> +      (version (git-version "0.0.0" revision commit))

I used "0.0.2" version, as specified in the main file. 

> +      (synopsis "Nicer, depth-colored citations for Gnus")

I removed "Nicer" marketing word.

> +      (description "This package this replaces the traditional chevron

I fixed the typo above.

> +citation marks @code{>} with a Unicode vertical bar with the same color as

I used @samp instead of @code. They have not the same purpose, although
they look the same.


Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index f45507c647..cdd9cea75d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21335,6 +21335,33 @@  DBI, and provides DB-accessing API and the simple management UI.")
 to open SQLite databases.")
       (license license:gpl3+))))
 
+(define-public emacs-nice-citation
+  (let ((commit "1013b56d9d1495a335f40a5f76203034dc5fa0ea")
+        (revision "0"))
+    (package
+      (name "emacs-nice-citation")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/damiencollard/nice-citation")
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "00xqr7haca5vd0bzd043lc6x4fjb903z96frz9b8cbd7spp63z7q"))
+                (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/damiencollard/nice-citation")
+      (synopsis "Nicer, depth-colored citations for Gnus")
+      (description "This package this replaces the traditional chevron
+citation marks @code{>} with a Unicode vertical bar with the same color as
+the text it is quoting.
+
+It is purely presentation: The underlying text is unchanged.  In particular,
+if you send an e-mail containing a citation, it will contain the traditional
+chevron marks.")
+      (license license:gpl3+))))
+
 (define-public emacs-nix-mode
   (package
     (name "emacs-nix-mode")