diff mbox series

[bug#49054] Add borg-sans-mono Font

Message ID fXYKhPovCQturjqN1NbjPux3aOs7f9f3F3sgcOjaD1Ch_-SFSJsgF0EJqFc8zhJC6MstpuTjwZw41DYyy7fXpmhmJ50dNKm_WTL8JZHpeuY=@protonmail.com
State Accepted
Headers show
Series [bug#49054] Add borg-sans-mono Font | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Charles June 19, 2021, 4:33 p.m. UTC
Thank you so much for reviewing my patch, and helping me correct it. Attatched is an fixed version.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Wednesday, June 16th, 2021 at 1:33 AM, Leo Prikler <leo.prikler@student.tugraz.at> wrote:

> Am Mittwoch, den 16.06.2021, 00:53 +0000 schrieb Charles:
>
> > This is my first contribution, so let me know if I did something
> >
> > wrong. The patch is attatched.
>
> > > Subject: [PATCH] gnu: Add font-borg-sans-mono
> > >
> > > -   gnu/packages/fonts.scm (font-borg-sans-mono): Add font
>
> Nitpicky, but the dot in the headerline is missing and we usually
>
> denote new packages by "new variable" since that's what they are on
>
> Scheme level.
>
> > -   (name "font-borg-sans-mono")
> > -   (version "0.3.0")
> > -   (home-page "https://github.com/charje/borg-sans-mono")
>
> home-page usually comes after build-system+arguments.
>
> > -         (uri (string-append
> >
> >
> > -               home-page
> >
> >
> > -               "/releases/download/v"
> >
> >
> > -               version
> >
> >
> > -               "/borg-sans-mono.zip"))
> >
> >
>
> Please type out home-page. It could very well be, that the devs start
>
> some fancy Github Pages website, which would break this code.
>
> > -   (description "Droid Sans Mono Slashed + Hasklig-style
> >
> >     ligatures!")
>
> This is not very descriptive at all, I'm afraid. If Hasklig or Monoid
>
> are a reasonable alternative to this font, it's probably easier to find
>
> a description for them.
>
> Regards,
>
> Leo

Comments

Leo Prikler June 19, 2021, 5:38 p.m. UTC | #1
Am Samstag, den 19.06.2021, 16:33 +0000 schrieb Charles:
> Thank you so much for reviewing my patch, and helping me correct it.
> Attatched is an fixed version.
I've pushed your patch with some cosmetic adjustments as listed below:
- instead of appending the package to the end, I added it after
Google's Roboto fonts
- I changed the git-reference to be a two-liner
- I changed the hash to be a three-liner as otherwise there'd be
problems with smaller screens and you don't want those.
- I reworded the description a little as the old one included a typo
and to me personally didn't really get the actual idea behind the
package across.

I missed, that the commit message still didn't follow the format 100%.
I ought to have corrected it to:

gnu: Add font-borg-sans-mono.

* gnu/packages/fonts.scm (font-borg-sans-mono): New variable.

Anyway, you should now be able to pull and build the font :)

All the best,
Leo
> 
> ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
> 
> On Wednesday, June 16th, 2021 at 1:33 AM, Leo Prikler <
> leo.prikler@student.tugraz.at> wrote:
> 
> > Am Mittwoch, den 16.06.2021, 00:53 +0000 schrieb Charles:
> > 
> > > This is my first contribution, so let me know if I did something
> > > 
> > > wrong. The patch is attatched.
> > > > Subject: [PATCH] gnu: Add font-borg-sans-mono
> > > > 
> > > > -   gnu/packages/fonts.scm (font-borg-sans-mono): Add font
> > 
> > Nitpicky, but the dot in the headerline is missing and we usually
> > 
> > denote new packages by "new variable" since that's what they are on
> > 
> > Scheme level.
> > 
> > > -   (name "font-borg-sans-mono")
> > > -   (version "0.3.0")
> > > -   (home-page "https://github.com/charje/borg-sans-mono")
> > 
> > home-page usually comes after build-system+arguments.
> > 
> > > -         (uri (string-append
> > > 
> > > 
> > > -               home-page
> > > 
> > > 
> > > -               "/releases/download/v"
> > > 
> > > 
> > > -               version
> > > 
> > > 
> > > -               "/borg-sans-mono.zip"))
> > > 
> > > 
> > 
> > Please type out home-page. It could very well be, that the devs
> > start
> > 
> > some fancy Github Pages website, which would break this code.
> > 
> > > -   (description "Droid Sans Mono Slashed + Hasklig-style
> > > 
> > >     ligatures!")
> > 
> > This is not very descriptive at all, I'm afraid. If Hasklig or
> > Monoid
> > 
> > are a reasonable alternative to this font, it's probably easier to
> > find
> > 
> > a description for them.
> > 
> > Regards,
> > 
> > Leo
diff mbox series

Patch

From cbaa3be124908c9ea0b78bb607032caefb78d067 Mon Sep 17 00:00:00 2001
From: Charles <charles.b.jackson@protonmail.com>
Date: Sat, 19 Jun 2021 11:21:13 -0500
Subject: [PATCH] gnu: Add new variable font-borg-sans-mono.

* gnu/packages/fonts.scm (font-borg-sans-mono): Add new variable.
---
 gnu/packages/fonts.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 973393acc4..5d3f2a8280 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2175,3 +2175,23 @@  neighborhood of Buenos Aires inspired Julieta Ulanovsky to design this
 typeface and rescue the beauty of urban typography that emerged in the first
 half of the twentieth century.")
     (license license:silofl1.1)))
+
+(define-public font-borg-sans-mono
+  (package
+    (name "font-borg-sans-mono")
+    (version "0.3.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/charje/borg-sans-mono/releases/download/v"
+             version
+             "/borg-sans-mono.zip"))
+       (sha256 (base32 "1xxakd9nfb8wz76rh0gbd69gh0mlqs2453g0j516xgxn8bxip2yj"))))
+    (build-system font-build-system)
+    (home-page "https://github.com/charje/borg-sans-mono")
+    (synopsis "The Borg Sans Mono font")
+    (description "Borg Sans Mono is a derivitive of Droid Sans Mono, a monospaced font
+designed for small screens. It has the additions of zero being slashed and
+programming ligatures for !=, /=, ==, ->, =>, <-, ===, and !===.")
+    (license license:asl2.0)))
-- 
2.32.0